app-admin/yadm: Security cleanup
authorSam James (sam_c) <sam@cmpct.info>
Sun, 29 Mar 2020 00:26:04 +0000 (00:26 +0000)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 31 Mar 2020 08:39:00 +0000 (11:39 +0300)
Bug: https://bugs.gentoo.org/625394
Signed-off-by: Sam James (sam_c) <sam@cmpct.info>
Closes: https://github.com/gentoo/gentoo/pull/15158
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-admin/yadm/Manifest
app-admin/yadm/yadm-1.12.0.ebuild [deleted file]

index 77a3614ccc961788e4d43b90f2fc9f7e43438639..2a3b64f3cdf26a1437acd8e6ea13fd436172104f 100644 (file)
@@ -1,2 +1 @@
-DIST yadm-1.12.0.tar.gz 47340 BLAKE2B ef710f56c96244c082bfcc887cae4aee00aaaadec5e7466500dde263c5e4f43df046e11742fd275e989bd9704b39a123f17248cd70d64f6ca552b28db6c44814 SHA512 402a67770154ce3ae7ab947ff4d4e26ca5040d343110fb749195ca5c3f4ee435aba1d8cdf02d4ecf4a81d3f331c1b891bed4fb3fcfcc893867e0fce45b9c8cd8
 DIST yadm-2.4.0.tar.gz 96877 BLAKE2B 462a5816e106c4502007ff34ab338904e14a9851ebcfc7ff79a32a8b11fbbe3e0b7e6538ed6b489ab67e2205c84b2250749e3091c77fa663886dc9792078a576 SHA512 43e16a9502f9dd9f6c6dba3bb5403bb048244a406d44cb42a96a43e62bf7342efd5f302304dbedede61423546787fc929f378d68da9031207e70239ec4e265ce
diff --git a/app-admin/yadm/yadm-1.12.0.ebuild b/app-admin/yadm/yadm-1.12.0.ebuild
deleted file mode 100644 (file)
index 55922bd..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit bash-completion-r1
-
-DESCRIPTION="A dotfile manager for the config files in your home folder"
-HOMEPAGE="https://github.com/TheLocehiliosan/yadm/"
-SRC_URI="https://github.com/TheLocehiliosan/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="zsh-completion test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
-       test? (
-               dev-tcltk/expect
-               dev-util/bats
-               dev-vcs/git
-       )"
-
-RDEPEND="
-       dev-vcs/git
-       app-crypt/gnupg
-       zsh-completion? ( app-shells/gentoo-zsh-completions )"
-
-src_compile() {
-       emake "${PN}.md"
-}
-
-src_test() {
-       # 109_accept_encryption tests are interactive, thus fail. Skip them
-       # 113_accept_jinja_alt.bats are depepending on the optional envtpl
-       while IFS="" read -d $'\0' -r f ; do
-               bats "${f}" || die "test ${f} failed"
-       done < <(find test -name '*.bats' -and -not -name '109_accept_encryption.bats' -and -not -name '113_accept_jinja_alt.bats' -print0)
-}
-
-src_install() {
-       einstalldocs
-
-       dobin "${PN}"
-       doman "${PN}.1"
-
-       dobashcomp completion/yadm.bash_completion
-
-       if use zsh-completion; then
-               insinto /usr/share/zsh/site-functions
-               newins completion/yadm.zsh_completion _${PN}
-       fi
-}