dev-python/pgspecial: Add tests, fix deps
authorMichał Górny <mgorny@gentoo.org>
Sun, 7 Jul 2019 13:28:12 +0000 (15:28 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 7 Jul 2019 13:30:10 +0000 (15:30 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pgspecial/pgspecial-1.11.5.ebuild

index edaec9de0592d60fdeed84952c5a0e7624e77bb5..4cd33f7650efd8a9867393c33aaa89ef99364c5a 100644 (file)
@@ -13,9 +13,22 @@ SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
 LICENSE="BSD MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
 
 RDEPEND="
        >=dev-python/click-4.1[${PYTHON_USEDEP}]
+       >=dev-python/psycopg-2.7.4[${PYTHON_USEDEP}]
        >=dev-python/python-sqlparse-0.1.19[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
 "
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               ${RDEPEND}
+               dev-python/pytest[${PYTHON_USEDEP}]
+       )"
+
+python_test() {
+       # tests/test_special.py require local postgres instance
+       pytest -vv tests/test_internal.py || die
+}