app-emulation/vmware-tools: Warn if no operating system is chosen, bug 488240
authorAndreas K. Huettel (dilfridge) <dilfridge@gentoo.org>
Sat, 12 Sep 2015 18:31:44 +0000 (20:31 +0200)
committerAndreas K. Huettel (dilfridge) <dilfridge@gentoo.org>
Sat, 12 Sep 2015 20:16:52 +0000 (22:16 +0200)
Package-Manager: portage-2.2.20.1

app-emulation/vmware-tools/vmware-tools-9.9.3.2780323.ebuild

index 790bbe60c101605b716e1bb745b028fbd59c362e..41cf86b775bdf041468f5990f46cb8393e14d794 100644 (file)
@@ -46,9 +46,13 @@ src_unpack() {
 
 src_install() {
        insinto "${VM_INSTALL_DIR}"/lib/vmware/isoimages
+       local somethingdone;
        local guest ; for guest in ${IUSE_VMWARE_GUEST} ; do
                if use "vmware_guest_${guest}" ; then
                        doins "${guest}".iso{,.sig}
+                       somethingdone=yes
                fi
        done
+
+       [ -n "${somethingdone}" ] || ewarn  "You should set VMWARE_GUEST in make.conf to specify which operating systems you need."
 }