app-editors/hexedit: Fix building against sys-libs/ncurses[tinfo] (bug #558298 by...
authorJeroen Roovers <jer@gentoo.org>
Fri, 21 Aug 2015 03:36:54 +0000 (05:36 +0200)
committerJeroen Roovers <jer@gentoo.org>
Fri, 21 Aug 2015 03:38:20 +0000 (05:38 +0200)
Package-Manager: portage-2.2.20.1

app-editors/hexedit/files/hexedit-1.2.13-tinfo.patch [new file with mode: 0644]
app-editors/hexedit/hexedit-1.2.13.ebuild

diff --git a/app-editors/hexedit/files/hexedit-1.2.13-tinfo.patch b/app-editors/hexedit/files/hexedit-1.2.13-tinfo.patch
new file mode 100644 (file)
index 0000000..86e7dba
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/configure.in
++++ b/configure.in
+@@ -37,6 +37,7 @@
+ AC_CHECK_LIB(curses, initscr, LIBS="$LIBS -lcurses",
+   AC_CHECK_LIB(ncurses, initscr, LIBS="$LIBS -lncurses")
+ )
++AC_SEARCH_LIBS(nodelay, tinfo)
+ AC_CHECK_FUNC(use_default_colors, 
+   AC_DEFINE(HAVE_COLORS, , "Define if you want colored (fruit salad) display option")
+ )
index f7a868c8eb8e3eb93cf42bcd6e77253338c92fb0..f7363a85fa12d1d4fac62e9f65f5b93fc7ea9fc2 100644 (file)
@@ -2,6 +2,9 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
+EAPI=5
+inherit autotools eutils
+
 DESCRIPTION="View and edit files in hex or ASCII"
 HOMEPAGE="http://rigaux.org/hexedit.html"
 SRC_URI="http://rigaux.org/${P}.src.tgz"
@@ -9,15 +12,20 @@ SRC_URI="http://rigaux.org/${P}.src.tgz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="alpha amd64 arm hppa ~mips ppc ppc64 s390 sh sparc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE=""
 
 DEPEND="sys-libs/ncurses"
 RDEPEND="${DEPEND}"
 
-S="${WORKDIR}/${PN}"
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+       epatch "${FILESDIR}"/${PN}-1.2.13-tinfo.patch
+       mv configure.in configure.ac || die
+       eautoreconf
+}
 
 src_install() {
-       dobin hexedit || die "dobin failed"
+       dobin hexedit
        doman hexedit.1
        dodoc Changes
 }