www-client/firefox: force stderr for ewarn in llvm_check_deps()
authorThomas Deutschmann <whissi@gentoo.org>
Thu, 31 Oct 2019 15:49:31 +0000 (16:49 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Thu, 31 Oct 2019 15:56:27 +0000 (16:56 +0100)
Closes: https://bugs.gentoo.org/695668
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
www-client/firefox/firefox-68.2.0.ebuild
www-client/firefox/firefox-70.0.ebuild

index b51a15732d01c1f6fba672465d7cff3afe4ae653..7c5b0d66a9e55d412d2b7164ee2097fe2b4e9172 100644 (file)
@@ -189,37 +189,36 @@ fi
 
 llvm_check_deps() {
        if ! has_version --host-root "sys-devel/clang:${LLVM_SLOT}" ; then
-               ewarn "sys-devel/clang:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
+               ewarn "sys-devel/clang:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
                return 1
        fi
 
-       if use pgo ; then
-               if ! has usersandbox $FEATURES ; then
-                       eerror "You must enable usersandbox as X server can not run as root!"
-               fi
-       fi
-
        if use clang ; then
                if ! has_version --host-root "=sys-devel/lld-${LLVM_SLOT}*" ; then
-                       ewarn "=sys-devel/lld-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
+                       ewarn "=sys-devel/lld-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
                        return 1
                fi
 
                if use pgo ; then
                        if ! has_version --host-root "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}*" ; then
-                               ewarn "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
+                               ewarn "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
                                return 1
                        fi
                fi
        fi
 
-       # <EAPI 7 workaround, #695668
        einfo "Will use LLVM slot ${LLVM_SLOT}!" >&2
 }
 
 pkg_setup() {
        moz_pkgsetup
 
+       if use pgo ; then
+               if ! has usersandbox $FEATURES ; then
+                       die "You must enable usersandbox as X server can not run as root!"
+               fi
+       fi
+
        # Avoid PGO profiling problems due to enviroment leakage
        # These should *always* be cleaned up anyway
        unset DBUS_SESSION_BUS_ADDRESS \
index c4e0acf078898e7b8201d13406c6da4fcc07cceb..e043eb8021038f410349afb1ab5b23f2a7ccd9ae 100644 (file)
@@ -192,37 +192,36 @@ fi
 
 llvm_check_deps() {
        if ! has_version --host-root "sys-devel/clang:${LLVM_SLOT}" ; then
-               ewarn "sys-devel/clang:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
+               ewarn "sys-devel/clang:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
                return 1
        fi
 
-       if use pgo ; then
-               if ! has usersandbox $FEATURES ; then
-                       eerror "You must enable usersandbox as X server can not run as root!"
-               fi
-       fi
-
        if use clang ; then
                if ! has_version --host-root "=sys-devel/lld-${LLVM_SLOT}*" ; then
-                       ewarn "=sys-devel/lld-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
+                       ewarn "=sys-devel/lld-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
                        return 1
                fi
 
                if use pgo ; then
                        if ! has_version --host-root "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}*" ; then
-                               ewarn "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
+                               ewarn "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
                                return 1
                        fi
                fi
        fi
 
-       # <EAPI 7 workaround, #695668
        einfo "Will use LLVM slot ${LLVM_SLOT}!" >&2
 }
 
 pkg_setup() {
        moz_pkgsetup
 
+       if use pgo ; then
+               if ! has usersandbox $FEATURES ; then
+                       die "You must enable usersandbox as X server can not run as root!"
+               fi
+       fi
+
        # Avoid PGO profiling problems due to enviroment leakage
        # These should *always* be cleaned up anyway
        unset DBUS_SESSION_BUS_ADDRESS \