dev-lang/go: remove 1.12.14
authorWilliam Hubbs <william.hubbs@sony.com>
Tue, 28 Jan 2020 15:54:56 +0000 (09:54 -0600)
committerWilliam Hubbs <williamh@gentoo.org>
Tue, 28 Jan 2020 15:55:44 +0000 (09:55 -0600)
Signed-off-by: William Hubbs <williamh@gentoo.org>
dev-lang/go/Manifest
dev-lang/go/go-1.12.14.ebuild [deleted file]

index 282aa9c5be69e829984b4ab7288660bf85a35983..1d514a293ad04933b9903e379067e75d2854b3b6 100644 (file)
@@ -10,6 +10,5 @@ DIST go-linux-ppc64le-bootstrap-1.8.tbz 52211575 BLAKE2B 7a28ec5a381369c4e9415c8
 DIST go-linux-s390x-bootstrap-1.8.tbz 57124869 BLAKE2B 920a176b8f4fc3a816e724324bbb30a383d599e31a0d2093d24797dbcd0e799a662a3589dbb87d2f5dd16df07c4cf8f1e444e87b540ec732746bb025dc9271f8 SHA512 d429cae870d66217ab2e07c74209d3031d97baa4f899b4d70ae6283a1a5b1434b037904c4cfca0b2bc798d5ba0b358c3739e000eccbc74809baf564c5686df5a
 DIST go-solaris-amd64-bootstrap-1.8.tbz 54926326 BLAKE2B 0a45312f090d81ebf46fe5950cb65c059e2801394231e715e94145d1f918eb59b10472b2385e57ebd5cfb9eca0ad7290fb118436486b665520bb540970f971ab SHA512 52b849e5b9a940e10de7ba3df0ebdf6e1c5d631de9581d936c9edf8f38e6bb3314acbc2b2d5202b0528fde2a359d52bc0c6f39acf9b1b614725e4b4a947ed10d
 DIST go1.12.13.src.tar.gz 21980338 BLAKE2B 205bee35a947ccd08f36547530e3de7928f5f3970be89580ddff80f7710dd1dcf4f292c10ec93c27717ce25ce2575f7151129430b80d1fb927872f891166d8db SHA512 a8210ba909c1bb26799625bbf648204dbef5a9f91af323277f76caee489f5912a08e9de686b71fe97d30c7dc171d5f4bcf8a2c2227d02353cfbb7d292c9efc22
-DIST go1.12.14.src.tar.gz 20726032 BLAKE2B 2defecd29568974c1618ce0da42d9e28ef41904ed3f759b51c7e392ed9dea950a4984efa333e52b413fab3dac8270bb99f60e113712bfc648c4c9af0e19aba7d SHA512 6cd225282fbade8bd7e96789744c7db07f223f5309358ca3768c95c34a099b44bd9ba9adc2ce293a5bbd608237ae6473b86e7bb451db395c647809fc2750dd4c
 DIST go1.12.15.src.tar.gz 20726294 BLAKE2B d123fc2328bf9db8f7337108e3d6857c31e10829096d47fb58519861b68bc0e2bdc9f032fc076666124ab418d3f37026107d6a853021fecbf26138bf00963572 SHA512 887e331c73b9d174e4a707a85be389fa0de43c77bc191ef5e0fe326ac7285374404450ca081cb8e92514a973d25d0314ca74eb17c8e53f8386e1798edd9d41aa
 DIST go1.13.6.src.tar.gz 21631050 BLAKE2B 8923021d5ff785f5422ee204ee81c986fc066a878a347bc73625974f05045689f694f76147c9bf7956dc59d6e3d3a543f0970e0716df8cd4f6556c28fe23808b SHA512 dffb6e06eea0b1541901dfbed8d28e8cc1eac3184dc40a19ed3637737df796a67a2e7170b228e1003d36b14e6f0f13bb8be9d2a702834a9c06228d1821659528
diff --git a/dev-lang/go/go-1.12.14.ebuild b/dev-lang/go/go-1.12.14.ebuild
deleted file mode 100644 (file)
index 5e3547c..0000000
+++ /dev/null
@@ -1,246 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-
-MY_PV=${PV/_/}
-
-inherit toolchain-funcs
-
-BOOTSTRAP_VERSION="bootstrap-1.8"
-BOOTSTRAP_DIST="https://dev.gentoo.org/~williamh/dist"
-BOOTSTRAP_URI="
-       ${BOOTSTRAP_DIST}/go-linux-amd64-${BOOTSTRAP_VERSION}.tbz
-       ${BOOTSTRAP_DIST}/go-linux-arm-${BOOTSTRAP_VERSION}.tbz
-       ${BOOTSTRAP_DIST}/go-linux-arm64-${BOOTSTRAP_VERSION}.tbz
-       ${BOOTSTRAP_DIST}/go-linux-ppc64-${BOOTSTRAP_VERSION}.tbz
-       ${BOOTSTRAP_DIST}/go-linux-ppc64le-${BOOTSTRAP_VERSION}.tbz
-       ${BOOTSTRAP_DIST}/go-linux-s390x-${BOOTSTRAP_VERSION}.tbz
-       ${BOOTSTRAP_DIST}/go-linux-386-${BOOTSTRAP_VERSION}.tbz
-       ${BOOTSTRAP_DIST}/go-freebsd-amd64-${BOOTSTRAP_VERSION}.tbz
-       ${BOOTSTRAP_DIST}/go-freebsd-386-${BOOTSTRAP_VERSION}.tbz
-       ${BOOTSTRAP_DIST}/go-darwin-amd64-${BOOTSTRAP_VERSION}.tbz
-       ${BOOTSTRAP_DIST}/go-solaris-amd64-${BOOTSTRAP_VERSION}.tbz
-"
-
-case ${PV}  in
-*9999*)
-       EGIT_REPO_URI="https://github.com/golang/go.git"
-       inherit git-r3
-       ;;
-*)
-       SRC_URI="https://storage.googleapis.com/golang/go${MY_PV}.src.tar.gz "
-       S="${WORKDIR}"/go
-       case ${PV} in
-       *_beta*|*_rc*) ;;
-       *)
-               KEYWORDS="-* ~amd64 ~arm ~arm64 ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
-               # The upstream tests fail under portage but pass if the build is
-               # run according to their documentation [1].
-               # I am restricting the tests on released versions until this is
-               # solved.
-               # [1] https://golang.org/issues/18442
-               RESTRICT="test"
-               ;;
-       esac
-esac
-
-# If gccgo or a previously installed version of dev-lang/go is not being
-# used to build Go, there is no way to know the architecture or operating system
-# of the build machine, so we need to download all of our bootstrap
-# archives to allow this ebuild to work under crossdev.
-#
-# https://bugs.gentoo.org/671394
-SRC_URI+="!gccgo? ( !system-bootstrap? ( ${BOOTSTRAP_URI} ) )"
-
-DESCRIPTION="A concurrent garbage collected and typesafe programming language"
-HOMEPAGE="https://golang.org"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-IUSE="gccgo system-bootstrap"
-
-BDEPEND="gccgo? ( >=sys-devel/gcc-5[go] )"
-RDEPEND="!<dev-go/go-tools-0_pre20150902"
-
-# These test data objects have writable/executable stacks.
-QA_EXECSTACK="
-       usr/lib/go/src/debug/elf/testdata/*.obj
-       usr/lib/go/src/*.gox
-       "
-
-# Do not complain about CFLAGS, etc, since Go doesn't use them.
-QA_FLAGS_IGNORED='.*'
-
-REQUIRES_EXCLUDE="/usr/lib/go/src/debug/elf/testdata/*"
-
-# The tools in /usr/lib/go should not cause the multilib-strict check to fail.
-QA_MULTILIB_PATHS="usr/lib/go/pkg/tool/.*/.*"
-
-# Do not strip this package. Stripping is unsupported upstream and may
-# fail.
-RESTRICT+=" strip"
-
-DOCS=(
-AUTHORS
-CONTRIBUTING.md
-CONTRIBUTORS
-PATENTS
-README.md
-)
-
-go_arch()
-{
-       # By chance most portage arch names match Go
-       local portage_arch=$(tc-arch $@)
-       case "${portage_arch}" in
-               x86)    echo 386;;
-               x64-*)  echo amd64;;
-               ppc64) [[ $(tc-endian $@) = big ]] && echo ppc64 || echo ppc64le ;;
-               s390) echo s390x ;;
-               *)              echo "${portage_arch}";;
-       esac
-}
-
-go_arm()
-{
-       case "${1:-${CHOST}}" in
-               armv5*) echo 5;;
-               armv6*) echo 6;;
-               armv7*) echo 7;;
-               *)
-                       die "unknown GOARM for ${1:-${CHOST}}"
-                       ;;
-       esac
-}
-
-go_os()
-{
-       case "${1:-${CHOST}}" in
-               *-linux*)       echo linux;;
-               *-darwin*)      echo darwin;;
-               *-freebsd*)     echo freebsd;;
-               *-netbsd*)      echo netbsd;;
-               *-openbsd*)     echo openbsd;;
-               *-solaris*)     echo solaris;;
-               *-cygwin*|*-interix*|*-winnt*)
-                       echo windows
-                       ;;
-               *)
-                       die "unknown GOOS for ${1:-${CHOST}}"
-                       ;;
-       esac
-}
-
-go_tuple()
-{
-       echo "$(go_os $@)_$(go_arch $@)"
-}
-
-go_cross_compile()
-{
-       [[ $(go_tuple ${CBUILD}) != $(go_tuple) ]]
-}
-
-pkg_pretend()
-{
-       # make.bash does not understand cross-compiling a cross-compiler
-       if [[ $(go_tuple) != $(go_tuple ${CTARGET}) ]]; then
-               die "CHOST CTARGET pair unsupported: CHOST=${CHOST} CTARGET=${CTARGET}"
-       fi
-       [[ ${MERGE_TYPE} != binary ]] &&
-               use system-bootstrap && ! has_version "dev-lang/go" &&
-               die "dev-lang/go must be installed to use the system-bootstrap use flag"
-}
-
-src_unpack()
-{
-       if [[ ${PV} = 9999 ]]; then
-               git-r3_src_unpack
-       else
-               unpack "go${MY_PV}.src.tar.gz"
-       fi
-       use gccgo || use system-bootstrap ||
-               unpack "go-$(go_os ${CBUILD})-$(go_arch ${CBUILD})-${BOOTSTRAP_VERSION}.tbz"
-}
-
-src_compile()
-{
-       export GOROOT_BOOTSTRAP="${WORKDIR}"/go-$(go_os ${CBUILD})-$(go_arch ${CBUILD})-bootstrap
-       if use gccgo; then
-               mkdir -p "${GOROOT_BOOTSTRAP}/bin" || die
-               local go_binary=$(gcc-config --get-bin-path)/go-$(gcc-major-version)
-               [[ -x ${go_binary} ]] || go_binary=$(
-                       find "${EPREFIX}"/usr/${CHOST}/gcc-bin/*/go-$(gcc-major-version) |
-                               sort -V | tail -n1)
-               [[ -x ${go_binary} ]] ||
-                       die "go-$(gcc-major-version): command not found"
-               ln -s "${go_binary}" "${GOROOT_BOOTSTRAP}/bin/go" || die
-       elif use system-bootstrap; then
-               export GOROOT_BOOTSTRAP="${EPREFIX}"/usr/lib/go
-       fi
-       export GOROOT_FINAL="${EPREFIX}"/usr/lib/go
-       export GOROOT="$(pwd)"
-       export GOBIN="${GOROOT}/bin"
-
-       # Go's build script does not use BUILD/HOST/TARGET consistently. :(
-       export GOHOSTARCH=$(go_arch ${CBUILD})
-       export GOHOSTOS=$(go_os ${CBUILD})
-       export CC=$(tc-getBUILD_CC)
-
-       export GOARCH=$(go_arch)
-       export GOOS=$(go_os)
-       export CC_FOR_TARGET=$(tc-getCC)
-       export CXX_FOR_TARGET=$(tc-getCXX)
-       if [[ ${ARCH} == arm ]]; then
-               export GOARM=$(go_arm)
-       fi
-
-       cd src
-       ./make.bash || die "build failed"
-}
-
-src_test()
-{
-       go_cross_compile && return 0
-
-       cd src
-       PATH="${GOBIN}:${PATH}" \
-       ./run.bash -no-rebuild || die "tests failed"
-}
-
-src_install()
-{
-       local bin_path f x
-
-       dodir /usr/lib/go
-
-       # There is a known issue which requires the source tree to be installed [1].
-       # Once this is fixed, we can consider using the doc use flag to control
-       # installing the doc and src directories.
-       # [1] https://golang.org/issue/2775
-       #
-       # deliberately use cp to retain permissions
-       cp -R api bin doc lib pkg misc src test "${ED}"/usr/lib/go
-       if go_cross_compile; then
-               bin_path="bin/$(go_tuple)"
-       else
-               bin_path=bin
-       fi
-       for x in ${bin_path}/*; do
-               f=${x##*/}
-               dosym ../lib/go/${bin_path}/${f} /usr/bin/${f}
-       done
-       einstalldocs
-
-       if [[ ${CHOST} == *-darwin* ]] ; then
-               # fix install_name for test object (binutils_test) on Darwin, it
-               # is never used in real circumstances
-               local libmac64="${EPREFIX}"/usr/lib/go/src/cmd/vendor/github.com/
-                     libmac64+=google/pprof/internal/binutils/testdata/lib_mac_64
-               install_name_tool -id "${libmac64}" "${D}${libmac64}"
-       fi
-}