dev-python/catkin_pkg: remove old
authorAlexis Ballier <aballier@gentoo.org>
Tue, 28 Feb 2017 08:23:21 +0000 (09:23 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 28 Feb 2017 11:26:48 +0000 (12:26 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-python/catkin_pkg/catkin_pkg-0.3.1-r1.ebuild [deleted file]

diff --git a/dev-python/catkin_pkg/catkin_pkg-0.3.1-r1.ebuild b/dev-python/catkin_pkg/catkin_pkg-0.3.1-r1.ebuild
deleted file mode 100644 (file)
index 57cbb8c..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
-       SCM="git-r3"
-       EGIT_REPO_URI="https://github.com/ros-infrastructure/catkin_pkg"
-fi
-
-inherit ${SCM} distutils-r1
-
-DESCRIPTION="Standalone Python library for the catkin package system"
-HOMEPAGE="http://wiki.ros.org/catkin_pkg"
-if [ "${PV#9999}" != "${PV}" ] ; then
-       SRC_URI=""
-       KEYWORDS=""
-else
-       SRC_URI="https://github.com/ros-infrastructure/catkin_pkg/archive/${PV}.tar.gz -> ${P}-gh.tar.gz"
-       KEYWORDS="~amd64 ~arm"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-
-RDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       dev-python/docutils[${PYTHON_USEDEP}]
-       dev-python/python-dateutil[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
-       test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
-"
-PATCHES=( "${FILESDIR}/catkin_prefix.patch" "${FILESDIR}/argparse.patch" )
-
-python_test() {
-       nosetests -s --tests test || die
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-       # Avoid recursing in the whole hierarchy
-       dodir /usr/
-       touch "${ED}/usr/CATKIN_IGNORE"
-}