dev-php/cli-prompt: Add 1.0.0 version
authorGuillaume Seren <guillaumeseren@gmail.com>
Thu, 24 Nov 2016 07:21:17 +0000 (08:21 +0100)
committerMichael Orlitzky <mjo@gentoo.org>
Sun, 18 Dec 2016 23:17:00 +0000 (18:17 -0500)
This is needed for composer-1.2.2, bug 439206.

Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
dev-php/cli-prompt/Manifest [new file with mode: 0644]
dev-php/cli-prompt/cli-prompt-1.0.0.ebuild [new file with mode: 0644]
dev-php/cli-prompt/files/autoload.php [new file with mode: 0644]
dev-php/cli-prompt/metadata.xml [new file with mode: 0644]

diff --git a/dev-php/cli-prompt/Manifest b/dev-php/cli-prompt/Manifest
new file mode 100644 (file)
index 0000000..4d50afb
--- /dev/null
@@ -0,0 +1 @@
+DIST cli-prompt-1.0.0.tar.gz 7538 SHA256 909e3a271e825d106d213700584e72333c93b8517f025079ec53717c2cc25db8 SHA512 5a1f6f999976f3b01d857890b5a06cfed377597397266b44d4aba324bedc2b9f73db5dc184ab40ee6632b43c80da99f5641366903bbc7bb7e18409cb367c8461 WHIRLPOOL aec289254cb73774aeb5ca799295c98ef82bcb8c6a67999ef0102421443bac485f66e1e517241b3df1015d1a886f96b4a8a107cd0d99698c6ebb2bc8e8cd0106
diff --git a/dev-php/cli-prompt/cli-prompt-1.0.0.ebuild b/dev-php/cli-prompt/cli-prompt-1.0.0.ebuild
new file mode 100644 (file)
index 0000000..5ac52f1
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Allows you to prompt for user input on the command line"
+HOMEPAGE="https://github.com/Seldaek/cli-prompt"
+SRC_URI="https://github.com/Seldaek/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       dev-lang/php:*
+       dev-php/fedora-autoloader"
+
+src_install() {
+       insinto "/usr/share/php/Seld/CliPrompt"
+       doins -r src/. "${FILESDIR}"/autoload.php
+       dodoc README.md
+}
diff --git a/dev-php/cli-prompt/files/autoload.php b/dev-php/cli-prompt/files/autoload.php
new file mode 100644 (file)
index 0000000..7a1acbd
--- /dev/null
@@ -0,0 +1,8 @@
+<?php
+/* Autoloader for symfony-finder and its dependencies */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+    require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+\Fedora\Autoloader\Autoload::addPsr4('Seld\\CliPrompt\\', __DIR__);
diff --git a/dev-php/cli-prompt/metadata.xml b/dev-php/cli-prompt/metadata.xml
new file mode 100644 (file)
index 0000000..4f48c5e
--- /dev/null
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <email>guillaumeseren@gmail.com</email>
+    <name>Guillaume Seren</name>
+  </maintainer>
+  <maintainer type="project">
+    <email>proxy-maint@gentoo.org</email>
+    <name>Proxy Maintainers</name>
+  </maintainer>
+  <longdescription>
+    Allows you to prompt for user input on the command line,
+    and optionally hide the characters they type.
+  </longdescription>
+</pkgmetadata>