Filtered hashval LDFLAG since it breaks the configure script. This fixes bug#125180.
authorMarkus Dittrich <markusle@gentoo.org>
Sat, 11 Mar 2006 20:23:03 +0000 (20:23 +0000)
committerMarkus Dittrich <markusle@gentoo.org>
Sat, 11 Mar 2006 20:23:03 +0000 (20:23 +0000)
Package-Manager: portage-2.1_pre5-r4

sci-mathematics/singular/ChangeLog
sci-mathematics/singular/Manifest
sci-mathematics/singular/singular-3.0.1.2.ebuild

index e6056c767d65f3a49992e33df701d6f238bf293e..5aa7f40edd8f820de0e2d8c00375c09e7b8cd018 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for sci-mathematics/singular
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/singular/ChangeLog,v 1.9 2006/03/06 11:41:44 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/singular/ChangeLog,v 1.10 2006/03/11 20:23:03 markusle Exp $
+
+  11 Mar 2006; Markus Dittrich <markusle@gentoo.org>
+  singular-3.0.1.2.ebuild:
+  Filtered hashval LDFLAG since it breaks the configure script. 
+  Thanks to Patrizio Bassi <hetfield666@gmail.com> for his help in 
+  debugging this. This fixes bug #125180.
 
   06 Mar 2006; Markus Dittrich <markusle@gentoo.org>
   singular-3.0.1.2.ebuild:
index 35d27bda7a1a5854fca384d513cd14ff8046461c..988f84a556558666de69f0b7e924f953c403f8e3 100644 (file)
@@ -1,6 +1,6 @@
-MD5 85e80f443f3dc8203a95c26775e001ef ChangeLog 4333
-RMD160 1eea52510c46ce6c9cc4683d38da8a375f483b6d ChangeLog 4333
-SHA256 508b0f37c251bbc4f085fafadc75c22fde1e3422f9cb1e277608ec95878f5677 ChangeLog 4333
+MD5 03731b7b78f60593bfd83c2d26b9a1a8 ChangeLog 4590
+RMD160 02804a06b61fc5dcdca99f0d2b9a6b7afe03702b ChangeLog 4590
+SHA256 462f45269be2b55bcfedaff4c86f94018dd60c5e815ac21264ab701d51a79bd0 ChangeLog 4590
 MD5 673cd925126b07ea0e78cf91269b7d66 files/digest-singular-2.0.5-r4 859
 RMD160 e8e8f57f50a91e84a4af63e3222011e9a696636f files/digest-singular-2.0.5-r4 859
 SHA256 643ada8e366c859a02d6dec1bf58cc0510a3462c833a347fa4ab95cf5b6e91c1 files/digest-singular-2.0.5-r4 859
@@ -28,6 +28,6 @@ SHA256 8bde53cf79771c990cc0114f85720a769c5c585502136960284f948c396395bb singular
 MD5 cd39e5ab8e6b0bb7d73746b86607dfb4 singular-3.0.1.1.ebuild 2869
 RMD160 39e95e631ac2328bfde4cba8ab2b696ad73169ed singular-3.0.1.1.ebuild 2869
 SHA256 28779526fa856c762b921896bc49fd89c2f06e57fc29390dd4121d980d0024cc singular-3.0.1.1.ebuild 2869
-MD5 1e1278528adaacc94d244f14c25604d1 singular-3.0.1.2.ebuild 2889
-RMD160 9a0fc76e4633097d9abf3ee383158d53b8a7a13a singular-3.0.1.2.ebuild 2889
-SHA256 2f827f9bccea69109052ccbc6352d825067838c5ab4caf4034866bb7bba6dc04 singular-3.0.1.2.ebuild 2889
+MD5 949bb7de0369cbf4741844e9eee0d9a2 singular-3.0.1.2.ebuild 3079
+RMD160 bbb24c3dea86f5ce8796b0ca477d82f3c180a2e1 singular-3.0.1.2.ebuild 3079
+SHA256 bebd82b0d506b69d86a824ef2e807db771dc2513e1f102e36b8cb1da15b230e4 singular-3.0.1.2.ebuild 3079
index 4ea35364916121aa5d1a5efb2caff929af7adcf3..4ab553fda53995005fc0e559cf698a50a48551b0 100644 (file)
@@ -1,8 +1,8 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/singular/singular-3.0.1.2.ebuild,v 1.3 2006/03/06 11:41:44 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/singular/singular-3.0.1.2.ebuild,v 1.4 2006/03/11 20:23:03 markusle Exp $
 
-inherit eutils
+inherit eutils flag-o-matic
 
 PV_MAJOR=${PV%.*}
 MY_PV=${PV//./-}
@@ -35,6 +35,13 @@ src_unpack () {
 }
 
 src_compile() {
+       # need to filter this LDFLAGS, otherwise the configure
+       # script chokes (see bug #125180)
+       filter-flags -Wl,-hashvals
+       filter-ldflags -hashvals
+       filter-ldflags -Wl,-hashvals
+
+
        local myconf="${myconf} --disable-doc --without-MP --with-factory --with-libfac --prefix=${S}"
        econf $(use_enable emacs) \
                ${myconf} || die "econf failed"