app-text/dvibook: update to EAPI=6
authorMike Frysinger <vapier@gentoo.org>
Sat, 21 Jan 2017 01:32:10 +0000 (19:32 -0600)
committerMike Frysinger <vapier@gentoo.org>
Sat, 21 Jan 2017 01:53:51 +0000 (19:53 -0600)
app-text/dvibook/dvibook-20001129.ebuild

index 7bd5977e70acf8e8294b25156ae870dbaf81a28f..bfe0374149f5880e8e72d5ddf41a83bd8976867d 100644 (file)
@@ -1,8 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
-inherit eutils
+EAPI="6"
+
+inherit toolchain-funcs
 
 DESCRIPTION="DVI file utilities: dvibook, dviconcat, dvitodvi, and dviselect"
 HOMEPAGE="http://www.ctan.org/tex-archive/dviware/dvibook/"
@@ -12,27 +13,25 @@ SRC_URI="mirror://gentoo/${P}.tar.gz"
 LICENSE="dvibook"
 SLOT="0"
 KEYWORDS="~amd64 ~ppc x86"
-
 IUSE=""
+
 DEPEND="x11-misc/imake
        x11-misc/gccmakedep
        app-text/rman"
 RDEPEND=""
 
-S=${WORKDIR}/${PN}
+S="${WORKDIR}/${PN}"
 
-src_unpack() {
-       unpack ${A}
-       epatch ${FILESDIR}/${P}.patch
-}
+PATCHES=(
+       "${FILESDIR}/${P}.patch"
+)
 
 src_compile() {
        xmkmf -a || die "xmkmf failed"
-       emake || die "emake failed"
+       emake CC="$(tc-getCC)"
 }
 
 src_install() {
-       make DESTDIR=${D} install install.man || die
-
+       emake DESTDIR="${D}" install install.man
        dodoc README
 }