sys-cluster/nova: Drop python2_7
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 28 Dec 2019 16:57:06 +0000 (17:57 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 29 Dec 2019 13:22:57 +0000 (14:22 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
sys-cluster/nova/nova-18.2.3.ebuild
sys-cluster/nova/nova-19.0.3.ebuild
sys-cluster/nova/nova-20.0.1.ebuild
sys-cluster/nova/nova-2018.2.9999.ebuild
sys-cluster/nova/nova-2019.1.9999.ebuild
sys-cluster/nova/nova-2019.2.9999.ebuild

index f57c926d0e3e51249e7f3f17e54427f06e33510c..e46324c4bd7329aac2504a25d3a9ef272027f52c 100644 (file)
@@ -2,8 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
 
+PYTHON_COMPAT=( python3_{5,6} )
 inherit distutils-r1 eutils linux-info multilib user
 
 DESCRIPTION="Cloud computing fabric controller (main part of an IaaS system) in Python"
@@ -151,7 +151,6 @@ RDEPEND="
        >=dev-python/taskflow-2.16.0[${PYTHON_USEDEP}]
        >=dev-python/python-dateutil-2.5.3[${PYTHON_USEDEP}]
        >=dev-python/zVMCloudConnector-1.1.1[${PYTHON_USEDEP}]
-       >=dev-python/futures-3.0.0[$(python_gen_usedep 'python2_7')]
        dev-python/libvirt-python[${PYTHON_USEDEP}]
        app-emulation/libvirt[iscsi?]
        novncproxy? ( www-apps/novnc )
index d25e3939bb401840a0018ef6c0dd7f02f37a756b..611fe7d129fe7e4f84c165c5693b2d9c21572ebb 100644 (file)
@@ -2,8 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
 
+PYTHON_COMPAT=( python3_{5,6,7} )
 inherit distutils-r1 eutils linux-info multilib user
 
 DESCRIPTION="Cloud computing fabric controller (main part of an IaaS system) in Python"
@@ -151,7 +151,6 @@ RDEPEND="
        >=dev-python/taskflow-2.16.0[${PYTHON_USEDEP}]
        >=dev-python/python-dateutil-2.5.3[${PYTHON_USEDEP}]
        >=dev-python/zVMCloudConnector-1.1.1[${PYTHON_USEDEP}]
-       >=dev-python/futurist-1.8.0[$(python_gen_usedep 'python2_7')]
        dev-python/libvirt-python[${PYTHON_USEDEP}]
        app-emulation/libvirt[iscsi?]
        app-emulation/spice-html5
index 721b0a62416cf25b7f8af399bc1597042c016832..a231a463c242ec5656b571d6a7b5edba41d30abc 100644 (file)
@@ -2,8 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
 
+PYTHON_COMPAT=( python3_{5,6,7} )
 inherit distutils-r1 eutils linux-info multilib user
 
 DESCRIPTION="Cloud computing fabric controller (main part of an IaaS system) in Python"
@@ -122,7 +122,6 @@ RDEPEND="
        >=dev-python/taskflow-2.16.0[${PYTHON_USEDEP}]
        >=dev-python/python-dateutil-2.5.3[${PYTHON_USEDEP}]
        >=dev-python/zVMCloudConnector-1.3.0[${PYTHON_USEDEP}]
-       >=dev-python/futurist-1.8.0[$(python_gen_usedep 'python2_7')]
        >=dev-python/openstacksdk-0.35.0[${PYTHON_USEDEP}]
        dev-python/libvirt-python[${PYTHON_USEDEP}]
        app-emulation/libvirt[iscsi?]
index dd30ccf5b5503a4169d1ffc46cdf5e208bf8bae3..38f09f336c86815ec292c31e248ddbec7c0f857d 100644 (file)
@@ -2,8 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
 
+PYTHON_COMPAT=( python3_{5,6} )
 inherit distutils-r1 eutils linux-info multilib user
 
 DESCRIPTION="Cloud computing fabric controller (main part of an IaaS system) in Python"
@@ -151,7 +151,6 @@ RDEPEND="
        >=dev-python/taskflow-2.16.0[${PYTHON_USEDEP}]
        >=dev-python/python-dateutil-2.5.3[${PYTHON_USEDEP}]
        >=dev-python/zVMCloudConnector-1.1.1[${PYTHON_USEDEP}]
-       >=dev-python/futures-3.0.0[$(python_gen_usedep 'python2_7')]
        dev-python/libvirt-python[${PYTHON_USEDEP}]
        app-emulation/libvirt[iscsi?]
        novncproxy? ( www-apps/novnc )
index 4eaf50a6619738be2887e97e38f5e8b00bc40d59..ce48df74dc278e4a3e1ac9280e69535449670b78 100644 (file)
@@ -2,8 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
 
+PYTHON_COMPAT=( python3_{5,6,7} )
 inherit distutils-r1 eutils linux-info multilib user
 
 DESCRIPTION="Cloud computing fabric controller (main part of an IaaS system) in Python"
@@ -151,7 +151,6 @@ RDEPEND="
        >=dev-python/taskflow-2.16.0[${PYTHON_USEDEP}]
        >=dev-python/python-dateutil-2.5.3[${PYTHON_USEDEP}]
        >=dev-python/zVMCloudConnector-1.1.1[${PYTHON_USEDEP}]
-       >=dev-python/futurist-1.8.0[$(python_gen_usedep 'python2_7')]
        dev-python/libvirt-python[${PYTHON_USEDEP}]
        app-emulation/libvirt[iscsi?]
        app-emulation/spice-html5
index 01dac558c9cb1e317aff0cb75a6d8cf5ab1086fd..e1d210b52cd007a465d6766ab4e7ba13b2f0ca28 100644 (file)
@@ -2,8 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
 
+PYTHON_COMPAT=( python3_{5,6,7} )
 inherit distutils-r1 eutils linux-info multilib user
 
 DESCRIPTION="Cloud computing fabric controller (main part of an IaaS system) in Python"
@@ -122,7 +122,6 @@ RDEPEND="
        >=dev-python/taskflow-2.16.0[${PYTHON_USEDEP}]
        >=dev-python/python-dateutil-2.5.3[${PYTHON_USEDEP}]
        >=dev-python/zVMCloudConnector-1.3.0[${PYTHON_USEDEP}]
-       >=dev-python/futurist-1.8.0[$(python_gen_usedep 'python2_7')]
        >=dev-python/openstacksdk-0.35.0[${PYTHON_USEDEP}]
        dev-python/libvirt-python[${PYTHON_USEDEP}]
        app-emulation/libvirt[iscsi?]