net-mail/automx: Switch to PYTHON_MULTI_USEDEP API
authorMichał Górny <mgorny@gentoo.org>
Sat, 8 Feb 2020 06:49:42 +0000 (07:49 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 9 Feb 2020 16:46:38 +0000 (17:46 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-mail/automx/automx-0.10.2-r1.ebuild
net-mail/automx/automx-0.10.2-r3.ebuild [moved from net-mail/automx/automx-0.10.2-r2.ebuild with 67% similarity]

index 8e254aba86e798d58dec3538b1b98801e8dd8070..272effe35240bfefb4d739c6e93b78a2b9c936f3 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -18,13 +18,15 @@ KEYWORDS="amd64 x86"
 IUSE="ldap memcached sql +tools"
 
 DEPEND="
-       dev-python/ipaddr[${PYTHON_USEDEP}]
-       dev-python/lxml[${PYTHON_USEDEP}]
-       dev-python/python-dateutil[${PYTHON_USEDEP}]
-       || ( www-apache/mod_wsgi[${PYTHON_USEDEP}] www-servers/uwsgi )
-       ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}]  )
-       memcached? ( dev-python/python-memcached[${PYTHON_USEDEP}] )
-       sql? ( dev-python/sqlalchemy[${PYTHON_USEDEP}] )
+       $(python_gen_cond_dep '
+               dev-python/ipaddr[${PYTHON_MULTI_USEDEP}]
+               dev-python/lxml[${PYTHON_MULTI_USEDEP}]
+               dev-python/python-dateutil[${PYTHON_MULTI_USEDEP}]
+               || ( www-apache/mod_wsgi[${PYTHON_MULTI_USEDEP}] www-servers/uwsgi )
+               ldap? ( dev-python/python-ldap[${PYTHON_MULTI_USEDEP}]  )
+               memcached? ( dev-python/python-memcached[${PYTHON_MULTI_USEDEP}] )
+               sql? ( dev-python/sqlalchemy[${PYTHON_MULTI_USEDEP}] )
+       ')
        tools? ( net-dns/bind-tools net-misc/wget )
        "
 RDEPEND="${DEPEND}"
similarity index 67%
rename from net-mail/automx/automx-0.10.2-r2.ebuild
rename to net-mail/automx/automx-0.10.2-r3.ebuild
index 83f6b39167bfe3b1a9aa056dbb21d44f7c825150..6c1f32ad9c3a979da7083c4e24003a15a028cb8b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -18,14 +18,16 @@ KEYWORDS="amd64 x86"
 IUSE="ldap memcached sql +tools"
 
 DEPEND="
-       dev-python/ipaddr[${PYTHON_USEDEP}]
-       dev-python/lxml[${PYTHON_USEDEP}]
-       dev-python/m2crypto[${PYTHON_USEDEP}]
-       dev-python/python-dateutil[${PYTHON_USEDEP}]
-       || ( www-apache/mod_wsgi[${PYTHON_USEDEP}] www-servers/uwsgi )
-       ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}]  )
-       memcached? ( dev-python/python-memcached[${PYTHON_USEDEP}] )
-       sql? ( dev-python/sqlalchemy[${PYTHON_USEDEP}] )
+       $(python_gen_cond_dep '
+               dev-python/ipaddr[${PYTHON_MULTI_USEDEP}]
+               dev-python/lxml[${PYTHON_MULTI_USEDEP}]
+               dev-python/m2crypto[${PYTHON_MULTI_USEDEP}]
+               dev-python/python-dateutil[${PYTHON_MULTI_USEDEP}]
+               || ( www-apache/mod_wsgi[${PYTHON_MULTI_USEDEP}] www-servers/uwsgi )
+               ldap? ( dev-python/python-ldap[${PYTHON_MULTI_USEDEP}]  )
+               memcached? ( dev-python/python-memcached[${PYTHON_MULTI_USEDEP}] )
+               sql? ( dev-python/sqlalchemy[${PYTHON_MULTI_USEDEP}] )
+       ')
        tools? ( net-dns/bind-tools net-misc/wget )
        "
 RDEPEND="${DEPEND}"