dev-libs/libdnet: Switch SRC_URI to GH
authorJeroen Roovers <jer@gentoo.org>
Sat, 16 Feb 2019 09:23:27 +0000 (10:23 +0100)
committerJeroen Roovers <jer@gentoo.org>
Sat, 16 Feb 2019 09:24:29 +0000 (10:24 +0100)
Package-Manager: Portage-2.3.60, Repoman-2.3.12
Fixes: https://bugs.gentoo.org/678078
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
dev-libs/libdnet/Manifest
dev-libs/libdnet/libdnet-1.12-r1.ebuild [new file with mode: 0644]

index 314c4a470fade5f69aff578dd8d73d96c9bd7634..7fb88bca285378cd0bb5d228e34df837f2a27f67 100644 (file)
@@ -1,2 +1,3 @@
 DIST libdnet-1.12.ipv6-1.patch.gz 5124 BLAKE2B 674866a441a5907df97942772b1e4b95aee004ddb110204df0580cec6b6bb3ba4074831d83e675e1914f1a29281b02227e95016db6ce6a0e8b99417d1aa6aaab SHA512 fa2380e41548ecdd978722930ecf90dffabd15cf06cbae0e113285072fe98a066f1e686b6d79e2d8b9f8adcf29783f313d61933b9e1e74e71da8dc7d741f815a
+DIST libdnet-1.12.tar.gz 959945 BLAKE2B a19f8c83425861d02f832330cf0eb5bc317eec157737e0eacd48a7827d423c626b24ce833f66429c9f2a0018502cae5426d5cfc1019aed307d63e4fa6b3845c8 SHA512 a2410a98b76d4bccecf7bcb82ff0b6e9fb809b389f7fea938cc42d94e18622cc5f353d2de737121a1990d9e16e9db8cc2f82677c94f78cd03c9227e815eab9e0
 DIST libdnet-1.12.tgz 970125 BLAKE2B 74be00b6fe1c7848010a7044628a6ad8f4b2f2c4f9676066c15e02c7a8b613e26a5e7743df524869fee2eb7d93438bf346f772b8df199b8ec337279dd50d5d77 SHA512 b763d2caa77b8d16b531142a5bce3b862ed20198406a00e1fe7f3b45ce308b97d638b0c7f03bd8593fdd206cc1645952839bc340b77537298a3df88599835bf3
diff --git a/dev-libs/libdnet/libdnet-1.12-r1.ebuild b/dev-libs/libdnet/libdnet-1.12-r1.ebuild
new file mode 100644 (file)
index 0000000..37fb381
--- /dev/null
@@ -0,0 +1,77 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+AT_M4DIR="config"
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_OPTIONAL=1
+inherit autotools distutils-r1
+
+DESCRIPTION="simplified, portable interface to several low-level networking routines"
+HOMEPAGE="https://github.com/dugsong/libdnet"
+SRC_URI="
+       ${HOMEPAGE}/archive/${P}.tar.gz
+       ipv6? ( https://fragroute-ipv6.googlecode.com/files/${P}.ipv6-1.patch.gz )
+"
+LICENSE="LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6 python static-libs test"
+
+DEPEND="
+       python? ( ${PYTHON_DEPS} )
+"
+RDEPEND="
+       ${DEPEND}
+"
+RESTRICT="test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+DOCS=( README THANKS TODO )
+S=${WORKDIR}/${PN}-${P}
+
+src_prepare() {
+       # Useless copy
+       rm -r trunk/ || die
+
+       sed -i \
+               -e 's/libcheck.a/libcheck.so/g' \
+               -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' \
+               configure.in || die
+       sed -i -e 's|-L@libdir@ ||g' dnet-config.in || die
+       use ipv6 && eapply "${WORKDIR}/${P}.ipv6-1.patch"
+       sed -i -e '/^SUBDIRS/s|python||g' Makefile.am || die
+       eautoreconf
+
+       if use python; then
+               cd python
+               distutils-r1_src_prepare
+       fi
+
+       eapply_user
+}
+
+src_configure() {
+       econf \
+               $(use_with python) \
+               $(use_enable static-libs static)
+}
+
+src_compile() {
+       default
+       if use python; then
+               cd python
+               distutils-r1_src_compile
+       fi
+}
+
+src_install() {
+       default
+       if use python; then
+               cd python
+               unset DOCS
+               distutils-r1_src_install
+       fi
+       find "${D}" -name '*.la' -delete || die
+}