sci-libs/ldl: new version 2.2.6.
authorMichael Orlitzky <mjo@gentoo.org>
Sat, 29 Feb 2020 02:25:22 +0000 (21:25 -0500)
committerMichael Orlitzky <mjo@gentoo.org>
Mon, 2 Mar 2020 17:20:44 +0000 (12:20 -0500)
Update to EAPI=7 and fix the HOMEPAGE, SRC_URI, and LICENSE. This is
part of a larger SuiteSparse v5.4.0 upgrade thanks to François Bissey
whose sage-on-gentoo ebuilds I'm using. There's a newer release
(v5.7.1) of SuiteSparse, but v5.4.0 has seen more testing.

Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
sci-libs/ldl/Manifest
sci-libs/ldl/ldl-2.2.6.ebuild [new file with mode: 0644]

index 664e6b55609879585e9953f09760420506047aca..e6b52388e27d21d80bf94657f879499928e76517 100644 (file)
@@ -1 +1,2 @@
 DIST ldl-2.1.0.tar.bz2 336442 BLAKE2B 8516e37ac66c329397739fb5d7ee0b3a5cc1a286d780062a749901a13b30dca52e131647e66a721be1f1e2ddd022ecc7c9d6ec5da81acc9c98afa53a06978367 SHA512 ad532e3481e48b9c3587ca0cba3d58a89a2174e3a0d523dcac6d420e04aa5da1cb8517bb14556d0a593110350fdc02aea3677eec41eb74821a3a63552418d0b5
+DIST ldl-2.2.6.tar.bz2 342923 BLAKE2B 7acf1a82824de013fe9a7742fb2d5c44c86de96e95d1d7408106d4af420dc3655ab7533eb80592b52523245c7545bc246bf129712547ff6eba856a807c78b6ad SHA512 266c9e62c474a6a9b2d7f74aa580e313fbe4b322197236ba6fbbab6d1756348cf146c1d807ea6d8d0e5941cedc48298e8437aaf386dd6c433dcaf41a9d0b7371
diff --git a/sci-libs/ldl/ldl-2.2.6.ebuild b/sci-libs/ldl/ldl-2.2.6.ebuild
new file mode 100644 (file)
index 0000000..6a1f2ac
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Simple but educational LDL^T matrix factorization algorithm"
+HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html"
+SRC_URI="http://202.36.178.9/sage/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc static-libs"
+
+BDEPEND="virtual/pkgconfig
+       doc? ( virtual/latex-base )"
+DEPEND="sci-libs/suitesparseconfig"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+       econf \
+               $(use_with doc) \
+               $(use_enable static-libs static)
+}