dev-python/pytest-cache: add python 3.7 support
authorVirgil Dupras <vdupras@gentoo.org>
Tue, 21 Aug 2018 01:51:45 +0000 (21:51 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Tue, 21 Aug 2018 02:09:56 +0000 (22:09 -0400)
Package-Manager: Portage-2.3.47, Repoman-2.3.10

dev-python/pytest-cache/pytest-cache-1.0-r2.ebuild [new file with mode: 0644]

diff --git a/dev-python/pytest-cache/pytest-cache-1.0-r2.ebuild b/dev-python/pytest-cache/pytest-cache-1.0-r2.ebuild
new file mode 100644 (file)
index 0000000..2b5ca62
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="mechanisms for caching across test runs"
+HOMEPAGE="https://pypi.org/project/pytest-cache/
+       https://bitbucket.org/hpk42/pytest-cache/
+       https://pythonhosted.org/pytest-cache/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/execnet[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+       "
+
+# https://bitbucket.org/hpk42/pytest-cache/issues/12
+RESTRICT=test
+
+python_test() {
+       PYTEST_PLUGINS="pytest_cache" py.test -v -v || die
+}