net-misc/nyx: add a -9999
authorJeffrey Lin <jeffrey@icurse.nl>
Tue, 2 Oct 2018 16:25:04 +0000 (12:25 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Sat, 6 Oct 2018 16:17:21 +0000 (12:17 -0400)
Signed-off-by: Jeffrey Lin <jeffrey@icurse.nl>
Package-Manager: Portage-2.3.49, Repoman-2.3.11
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
net-misc/nyx/nyx-9999.ebuild [new file with mode: 0644]

diff --git a/net-misc/nyx/nyx-9999.ebuild b/net-misc/nyx/nyx-9999.ebuild
new file mode 100644 (file)
index 0000000..a27cb04
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+inherit vcs-snapshot distutils-r1
+
+DESCRIPTION="Utility to monitor real time Tor status information"
+HOMEPAGE="https://nyx.torproject.org"
+if [[ ${PV} == *9999* ]]; then
+       EGIT_REPO_URI="https://git.torproject.org/nyx.git"
+       inherit git-r3
+else
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+       net-libs/stem
+       net-vpn/tor"