dev-python/css-parser: add Python3.7 support, EAPI=7
authorZamarin Arthur <arthurzam@gmail.com>
Wed, 8 May 2019 07:12:55 +0000 (10:12 +0300)
committerZac Medico <zmedico@gentoo.org>
Wed, 8 May 2019 17:26:04 +0000 (10:26 -0700)
Closes: https://github.com/gentoo/gentoo/pull/11936
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Zamarin Arthur <arthurzam@gmail.com>
Signed-off-by: Zac Medico <zmedico@gentoo.org>
dev-python/css-parser/css-parser-1.0.4-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/css-parser/css-parser-1.0.4-r1.ebuild b/dev-python/css-parser/css-parser-1.0.4-r1.ebuild
new file mode 100644 (file)
index 0000000..29254e6
--- /dev/null
@@ -0,0 +1,17 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A CSS Cascading Style Sheets library (fork of cssutils)"
+HOMEPAGE="https://pypi.org/project/css-parser/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"