Revision bump in order to resolve bug #145085
authorYuval Yaari <yuval@gentoo.org>
Wed, 6 Sep 2006 09:34:12 +0000 (09:34 +0000)
committerYuval Yaari <yuval@gentoo.org>
Wed, 6 Sep 2006 09:34:12 +0000 (09:34 +0000)
Package-Manager: portage-2.1-r1

dev-libs/syck/ChangeLog
dev-libs/syck/files/digest-syck-0.55-r2 [new file with mode: 0644]
dev-libs/syck/syck-0.55-r2.ebuild [new file with mode: 0644]

index 58efcdd0ba456d34dfccb492e14e3224a3d02c02..8d41eca6ed91da5b34dba821789366a9914d7da3 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for dev-libs/syck
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/syck/ChangeLog,v 1.8 2006/08/22 15:12:29 yuval Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/syck/ChangeLog,v 1.9 2006/09/06 09:34:12 yuval Exp $
+
+*syck-0.55-r2 (06 Sep 2006)
+
+  06 Sep 2006; Yuval Yaari <yuval@gentoo.org> +syck-0.55-r2.ebuild:
+  Revision bump in order to resolve bug #145085
 
 *syck-0.55-r1 (22 Aug 2006)
 
diff --git a/dev-libs/syck/files/digest-syck-0.55-r2 b/dev-libs/syck/files/digest-syck-0.55-r2
new file mode 100644 (file)
index 0000000..36797fd
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 a57b7c46d81170b9318e2f384f77910c syck-0.55.tar.gz 354205
+RMD160 ffd26db70cf743b90cbfecfe7402c6fb8d698ee8 syck-0.55.tar.gz 354205
+SHA256 ac881945c9dfe5dd6395a5db921e8256d1d359295bb66a1acbfe49fb637c1a3a syck-0.55.tar.gz 354205
diff --git a/dev-libs/syck/syck-0.55-r2.ebuild b/dev-libs/syck/syck-0.55-r2.ebuild
new file mode 100644 (file)
index 0000000..789ef37
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/syck/syck-0.55-r2.ebuild,v 1.1 2006/09/06 09:34:12 yuval Exp $
+
+RUBY_OPTIONAL="yes"
+inherit flag-o-matic distutils ruby
+
+IUSE="python ruby"
+DESCRIPTION="Syck is an extension for reading and writing YAML swiftly in popular scripting languages."
+HOMEPAGE="http://whytheluckystiff.net/syck/"
+SRC_URI="http://rubyforge.org/frs/download.php/4492/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+DEPEND="sys-libs/glibc
+               ruby? ( dev-lang/ruby
+                       dev-ruby/racc
+               )
+               python? ( dev-lang/python )
+       !=dev-libs/syck-0.55-r1"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+       append-flags -fPIC
+       econf
+       emake
+
+       if use python; then
+               pushd ext/python
+               distutils_src_compile
+               popd
+       fi
+
+       if use ruby; then
+               pushd ext/ruby
+               ruby_econf
+               ruby_emake
+               popd
+       fi
+}
+
+src_install() {
+       einstall
+
+       if use python; then
+               pushd ext/python
+               distutils_src_install
+               popd
+       fi
+
+       if use ruby; then
+               pushd ext/ruby
+               ruby_einstall
+               popd
+       fi
+}