x11-libs/vte: bump to 0.54.1
authorMart Raudsepp <leio@gentoo.org>
Sat, 6 Oct 2018 13:11:33 +0000 (16:11 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sat, 6 Oct 2018 13:24:33 +0000 (16:24 +0300)
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Package-Manager: Portage-2.3.49, Repoman-2.3.11

x11-libs/vte/Manifest
x11-libs/vte/vte-0.54.1.ebuild [new file with mode: 0644]

index c322719a48f508aea7f43d633f86d3920a2f2338..493df3d82e0fac7e0fbc0c9ab82285a1b6ea9851 100644 (file)
@@ -4,3 +4,5 @@ DIST vte-0.48.4-command-notify.patch.xz 5500 BLAKE2B 88b655403d2bef034604a283b17
 DIST vte-0.48.4.tar.xz 1008296 BLAKE2B 9f946d6909d38896ec80db2a02666d809155997b27109724fb318d28200220f1514fb23e4cdc90263a756914b5db442c947578c8854a535cb960a06f7bc03a77 SHA512 4b75bd881e58b5043bc44e391ef3a826a2c25d0f1bb5ffb890367e11a60b1bcbce091575ede6972a89ae043b39c51897f91fca1faf6872664d602e503d8020fc
 DIST vte-0.53.91-command-notify.patch.xz 3336 BLAKE2B f1eb7ce8ae5a975028474e0d31b14a35722cc32578dcb68905ec92b0ca048c8e1b7c903c7195248435db58a6cc60afce7376b38a3606b8ec88c8f28a7c127f71 SHA512 aab84dd050b5b9f59e9dc5e17a41a27f4650aecbd3fcb847b63b9bb79c84d3e544212e6cf6b4693424a44e14f8576c4f54eaea70a211dc0c40ae5887ca6114e8
 DIST vte-0.54.0.tar.xz 1082032 BLAKE2B 6349a7d7d04df26be3fca3c414aecd00e8a25b912af39446a412cd86c8b0165977933945786e840e2ed39d0f2fa8d51f2fc8052f00f56e47b4f1d62ffa00b968 SHA512 69dd0caae4eacc179f84eccf98625a31140286beca4244a8f06420bd36ac62dcaddf9e9d8b114549ca97927e94b562df3e7daa9fad971484f05ebdd1c0f7b787
+DIST vte-0.54.1-command-notify.patch.xz 3428 BLAKE2B 75b0c22720276300be2e49e8444aa68fed77fb7a6cc6b0e93a5c2d41257626bd60ff1084d68579769cb3d85e7ec567927591746de48e860b138d0c1f24f64cc7 SHA512 a53da569f8168c8e9e21e186dcfc00bf9fdb78a0c767ba35033c1c1e4f836406b4d9bf70ee3e071f6c749fd6f72101a6960d201617bd0bc23021e1eeaac6fd0c
+DIST vte-0.54.1.tar.xz 1083552 BLAKE2B 1e52275c953b5fbf51a1cc727dfca0bde3cc8f51a18055cd0c65c949479d0b4d926466016fa7d6f6dbebc9117c1b6fbde9a4bde38c5d82bb44ecce8612290de6 SHA512 5cb866e75c35e1b5728d17b0433641ceb4837495d59185a04fde9dd8c9849ab905a6b2718a50b27cc70323c7a6c5db31a808816576c30d7f18ece889a329fb61
diff --git a/x11-libs/vte/vte-0.54.1.ebuild b/x11-libs/vte/vte-0.54.1.ebuild
new file mode 100644 (file)
index 0000000..f8c6fcc
--- /dev/null
@@ -0,0 +1,88 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+VALA_USE_DEPEND="vapigen"
+VALA_MIN_API_VERSION="0.32"
+
+inherit gnome2 vala
+
+DESCRIPTION="Library providing a virtual terminal emulator widget"
+HOMEPAGE="https://wiki.gnome.org/action/show/Apps/Terminal/VTE"
+
+LICENSE="LGPL-2+"
+SLOT="2.91"
+IUSE="+crypt debug glade +introspection vala vanilla"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+REQUIRED_USE="vala? ( introspection )"
+
+SRC_URI="${SRC_URI} !vanilla? ( https://dev.gentoo.org/~leio/distfiles/${P}-command-notify.patch.xz )"
+
+RDEPEND="
+       >=dev-libs/glib-2.40:2
+       >=dev-libs/libpcre2-10.21
+       >=x11-libs/gtk+-3.16:3[introspection?]
+       >=x11-libs/pango-1.22.0
+
+       sys-libs/ncurses:0=
+       sys-libs/zlib
+
+       crypt?  ( >=net-libs/gnutls-3.2.7:0= )
+       glade? ( >=dev-util/glade-3.9:3.10 )
+       introspection? ( >=dev-libs/gobject-introspection-0.9.0:= )
+"
+DEPEND="${RDEPEND}
+       dev-libs/libxml2:2
+       dev-util/glib-utils
+       >=dev-util/gtk-doc-am-1.13
+       >=dev-util/intltool-0.35
+       sys-devel/gettext
+       virtual/pkgconfig
+
+       vala? ( $(vala_depend) )
+"
+RDEPEND="${RDEPEND}
+       !x11-libs/vte:2.90[glade]
+"
+
+src_prepare() {
+       if ! use vanilla; then
+               # First half of http://pkgs.fedoraproject.org/cgit/rpms/vte291.git/tree/vte291-command-notify-scroll-speed.patch
+               # Adds OSC 777 support for desktop notifications in gnome-terminal or elsewhere
+               eapply "${WORKDIR}"/${P}-command-notify.patch
+       fi
+
+       use vala && vala_src_prepare
+
+       # build fails because of -Werror with gcc-5.x
+       sed -e 's#-Werror=format=2#-Wformat=2#' -i configure || die "sed failed"
+
+       gnome2_src_prepare
+}
+
+src_configure() {
+       local myconf=""
+
+       if [[ ${CHOST} == *-interix* ]]; then
+               myconf="${myconf} --disable-Bsymbolic"
+
+               # interix stropts.h is empty...
+               export ac_cv_header_stropts_h=no
+       fi
+
+       gnome2_src_configure \
+               --disable-static \
+               --with-gtk=3.0 \
+               --with-iconv \
+               $(use_enable debug) \
+               $(use_enable glade glade-catalogue) \
+               $(use_with crypt gnutls) \
+               $(use_enable introspection) \
+               $(use_enable vala) \
+               ${myconf}
+}
+
+src_install() {
+       gnome2_src_install
+       mv "${ED}"/etc/profile.d/vte{,-${SLOT}}.sh || die
+}