dev-python/billiard: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Thu, 26 Mar 2020 13:43:18 +0000 (14:43 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 26 Mar 2020 13:43:18 +0000 (14:43 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/billiard/Manifest
dev-python/billiard/billiard-3.5.0.2.ebuild [deleted file]

index 2a7f46aeb42c996f10750835031cd0e535ecc969..a85d3d00ba3d31c05ea495d20981cd3de71103f4 100644 (file)
@@ -1,2 +1 @@
-DIST billiard-3.5.0.2.tar.gz 157299 BLAKE2B 1400d5a562dcab33c83a64cc7f7d14ad55b75677c3bb4c050cd4ba08a1f882e65d033653628fc3f2b52942081da3d5661fb0bcc5f2dd95f81a64749cd47d324f SHA512 581e1ac361324b36d79e280072952e490ef3470709b094f001c579feda54578c8e7b3e5afc93a5f878a6118c56afff7e59e13b3d3f2ccb2564b9b27cc810dae7
 DIST billiard-3.6.0.0.tar.gz 151342 BLAKE2B 46e29ae54144f3b4ebf3fbb4a5bdbba29662d3a6b292cbfef526618237103fd833d10eefe03211141264424590b33ddcd8722616d36ab4e2405198628cc29d5a SHA512 0a71de026d2a781b83fe2c549ecbfe9b6fbd574d8067fc46ba7eca6b76633a123620853d22696df3563d050043cfe75b14b4b69bf5217e0af964aaa0bcbe08ff
diff --git a/dev-python/billiard/billiard-3.5.0.2.ebuild b/dev-python/billiard/billiard-3.5.0.2.ebuild
deleted file mode 100644 (file)
index dd6ede0..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 pypy3 )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Python multiprocessing fork"
-HOMEPAGE="https://pypi.org/project/billiard/ https://github.com/celery/billiard"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               >=dev-python/case-1.3.1[${PYTHON_USEDEP}]
-               >=dev-python/pytest-3.0[${PYTHON_USEDEP}]
-       )"
-# The usual req'd for tests
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile() {
-       if !  python_is_python3; then
-               local CFLAGS=${CFLAGS}
-               append-cflags -fno-strict-aliasing
-       fi
-       distutils-r1_python_compile
-}
-
-python_compile_all() {
-       use doc && esetup.py build_sphinx --builder="html" --source-dir=Doc/
-}
-
-python_test() {
-       esetup.py test
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( build/sphinx/html/. )
-       distutils-r1_python_install_all
-}