app-crypt/yubikey-manager: bump to 3.0.0
authorGöktürk Yüksek <gokturk@gentoo.org>
Mon, 5 Aug 2019 04:19:04 +0000 (00:19 -0400)
committerGöktürk Yüksek <gokturk@gentoo.org>
Mon, 5 Aug 2019 04:42:29 +0000 (00:42 -0400)
Package-Manager: Portage-2.3.67, Repoman-2.3.12
Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
app-crypt/yubikey-manager/Manifest
app-crypt/yubikey-manager/yubikey-manager-3.0.0.ebuild [new file with mode: 0644]

index 11599f39cf2f64e82cbbe52661b5747fd7f6ea7f..27ef2fdc3640087ac3467b05c0353bfefc1fc0ea 100644 (file)
@@ -4,3 +4,4 @@ DIST yubikey-manager-1.0.0.tar.gz 90653 BLAKE2B 5d8522181ad460521995d3cae63976e0
 DIST yubikey-manager-2.0.0.tar.gz 102078 BLAKE2B a2b8f90dabefb1014881cbe709222bf5cb48c9f409b415a8a2b27d7101c2da6189d0ebfe21a2701d10798c48c44e546659f9424ba6bf9257f7311abb0fc90b9b SHA512 42bebb88ba78bcce00a228109d0b4c815b3242ddbe43fd26c1209ba8666eb033ab77d5acd39a157e8310ce327de8d38bf88cfa0ffaed6273236b220c39e72e3b
 DIST yubikey-manager-2.1.0.tar.gz 132797 BLAKE2B 39a170901dd10443f7cd639d1f525b12074ed042f606c083fe5b1bf04f463f608c4968c1e7f06dd057ff519a2a4bf712d36643e7db164ef92a3152ea5fb7ae15 SHA512 05cc1a106ffd2b40bc0a1286fa2f9c19f022bc7db04b85c9aaab3c67cad92a0c8ee4ba70f9b62ffa7f02ce67525a7d5f03bf9160b9bbe38909232cf75eb39373
 DIST yubikey-manager-2.1.1.tar.gz 101672 BLAKE2B baafce3850c0cbed842508c93ec4ad71e0eebbd0dcc61833b245b6c62f74b7215519cb8b1ec82df3be8c7677ec24447193a0121e0a63e67615453c2c6032fc0a SHA512 2c5990d9421acf93113347e9b9d33af893765ae9c5d9e6c9c4f2db1274b84cd839c15ae74327bdcbe9ec32ebdbcbed95b172b8b13ac00bbeb17eb06b6dd71ccd
+DIST yubikey-manager-3.0.0.tar.gz 138225 BLAKE2B 8506f7cc4d6579c1905d565d5d32a7e745389000ff67786e5b5e6bc54793230321e5f0f4840c625cae0a4d9d2893b75910bebb3207cfc75189d3a4876838a712 SHA512 47ae785356c256f31e118f2df483d3a0d7fb7b5b380fd7cd207334daaa47319855bde41931099f9acb6b310d4ba824540ab5d3008384fd4d6a373da7355b18eb
diff --git a/app-crypt/yubikey-manager/yubikey-manager-3.0.0.ebuild b/app-crypt/yubikey-manager/yubikey-manager-3.0.0.ebuild
new file mode 100644 (file)
index 0000000..cf74d5b
--- /dev/null
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{5,6}} )
+inherit readme.gentoo-r1 distutils-r1
+
+DESCRIPTION="Python library and command line tool for configuring a YubiKey"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager/"
+# Per https://github.com/Yubico/yubikey-manager/issues/217, Yubico is
+# the official source for tarballs, not Github
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+       dev-python/click[${PYTHON_USEDEP}]
+       dev-python/cryptography[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
+       >=dev-python/fido2-0.7.0[${PYTHON_USEDEP}]
+       dev-python/pyopenssl[${PYTHON_USEDEP}]
+       dev-python/pyscard[${PYTHON_USEDEP}]
+       dev-python/pyusb[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]
+       >=sys-auth/ykpers-1.19.0
+"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               ${RDEPEND}
+               $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2_7')
+       )
+"
+
+python_test() {
+       esetup.py test
+}
+
+python_install_all() {
+       local DOC_CONTENTS
+
+       distutils-r1_python_install_all
+
+       DOC_CONTENTS="
+               The 'openpgp' command may require the package 'app-crypt/ccid'
+               to be installed on the system. Furthermore, make sure that pcscd
+               daemon is running and has correct access permissions to USB
+               devices.
+       "
+       readme.gentoo_create_doc
+
+       doman "${S}"/man/ykman.1
+}
+
+pkg_postinst() {
+       readme.gentoo_print_elog
+}