games-arcade/nibbles: tweak for gcc-10, bug #706446
authorSergei Trofimovich <slyfox@gentoo.org>
Sun, 26 Jan 2020 15:17:01 +0000 (15:17 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Sun, 26 Jan 2020 15:17:08 +0000 (15:17 +0000)
Reported-by: Toralf Förster
Closes: https://bugs.gentoo.org/706446
Package-Manager: Portage-2.3.85, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
games-arcade/nibbles/files/nibbles-0.0.4-gcc-10.patch [new file with mode: 0644]
games-arcade/nibbles/nibbles-0.0.4-r1.ebuild

diff --git a/games-arcade/nibbles/files/nibbles-0.0.4-gcc-10.patch b/games-arcade/nibbles/files/nibbles-0.0.4-gcc-10.patch
new file mode 100644 (file)
index 0000000..e70203f
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/scoring.c
++++ b/scoring.c
+@@ -12,6 +12,8 @@
+ #include <time.h>
+ #include "scoring.h"
++char highscoref[255];
++
+ int get_high_scores(struct highscoreent *highscores[], int *numscores)
+ {
+       FILE *scorefile;
+--- a/scoring.h
++++ b/scoring.h
+@@ -11,7 +11,7 @@
+ /* Max number of high scores we store */
+ #define MAXHIGHSCORES 20
+-char highscoref[255];
++extern char highscoref[255];
+ struct highscoreent {
+       char name[16];
index fb8b322939727d375af480cf8c4a3c203fa18179..f0e8881182455ea3409db3f3588f707ced5f0280 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -24,6 +24,7 @@ GAMES_STATEDIR="/var/games/${PN}"
 
 PATCHES=(
        "${FILESDIR}"/${P}-as-needed.patch
+       "${FILESDIR}"/${P}-gcc-10.patch
 )
 
 S="${WORKDIR}/${MY_P}"