app-admin/consul: inherit go-build for GOPATH setting with get_golibdir_gopath
authorZac Medico <zmedico@gentoo.org>
Mon, 10 Aug 2015 05:20:27 +0000 (22:20 -0700)
committerZac Medico <zmedico@gentoo.org>
Mon, 10 Aug 2015 05:35:16 +0000 (22:35 -0700)
Package-Manager: portage-2.2.20

app-admin/consul/consul-0.5.2-r1.ebuild
app-admin/consul/consul-0.5.2.ebuild
app-admin/consul/consul-9999.ebuild

index 6fec48bdf537dd02017f7950ef67d20bcdc5b78e..a55ecdff9b5b9a821a36c589d3b076cbadd0100c 100644 (file)
@@ -4,7 +4,7 @@
 
 EAPI=5
 
-inherit systemd user
+inherit golang-base systemd user
 
 KEYWORDS="~amd64"
 DESCRIPTION="A tool for service discovery, monitoring and configuration"
@@ -13,6 +13,7 @@ GO_PN="github.com/hashicorp/consul"
 LICENSE="MPL-2.0"
 SLOT="0"
 IUSE="test web"
+RESTRICT="test"
 
 DEPEND=">=dev-lang/go-1.4:=
        dev-go/go-crypto:=
@@ -89,7 +90,7 @@ src_unpack() {
        unpack_go_packages
        # Create a writable GOROOT in order to avoid sandbox violations
        # or other interference from installed instances.
-       export GOPATH="${WORKDIR}" GOROOT="${WORKDIR}/goroot"
+       export GOPATH="${WORKDIR}:$(get_golibdir_gopath)" GOROOT="${WORKDIR}/goroot"
        cp -sR "${EPREFIX}"/usr/lib/go "${GOROOT}" || die
        while read -r path; do
                rm -rf "${GOROOT}/src/${path#${WORKDIR}/src}" \
index 9c47b7fa54e18af5089d5d20183662662068d692..83890455ffa50ba2b758764eb7460cd033d6fe6b 100644 (file)
@@ -4,7 +4,7 @@
 
 EAPI=5
 
-inherit systemd user
+inherit golang-base systemd user
 
 KEYWORDS="~amd64"
 DESCRIPTION="A tool for service discovery, monitoring and configuration"
@@ -13,6 +13,7 @@ GO_PN="github.com/hashicorp/consul"
 LICENSE="MPL-2.0"
 SLOT="0"
 IUSE="test web"
+RESTRICT="test"
 
 DEPEND=">=dev-lang/go-1.4
        dev-go/go-crypto
@@ -89,7 +90,7 @@ src_unpack() {
        unpack_go_packages
        # Create a writable GOROOT in order to avoid sandbox violations
        # or other interference from installed instances.
-       export GOPATH="${WORKDIR}" GOROOT="${WORKDIR}/goroot"
+       export GOPATH="${WORKDIR}:$(get_golibdir_gopath)" GOROOT="${WORKDIR}/goroot"
        cp -sR "${EPREFIX}"/usr/lib/go "${GOROOT}" || die
        while read -r path; do
                rm -rf "${GOROOT}/src/${path#${WORKDIR}/src}" \
index 49971f1f012a30fc739cda230d2a5087d535b901..3c38c200dad4ebc196362a46bc4f21cdc9f3e6c9 100644 (file)
@@ -4,7 +4,7 @@
 
 EAPI=5
 
-inherit git-r3 systemd user
+inherit git-r3 golang-base systemd user
 
 KEYWORDS=""
 DESCRIPTION="A tool for service discovery, monitoring and configuration"
@@ -14,6 +14,7 @@ EGIT_REPO_URI="git://${GO_PN}.git"
 LICENSE="MPL-2.0"
 SLOT="0"
 IUSE="test web"
+RESTRICT="test"
 
 DEPEND=">=dev-lang/go-1.4:=
        dev-go/go-crypto:=
@@ -40,7 +41,7 @@ src_unpack() {
 
        # Create a writable GOROOT in order to avoid sandbox violations
        # or other interference from installed instances.
-       export GOPATH="${WORKDIR}" GOROOT="${WORKDIR}/goroot"
+       export GOPATH="${WORKDIR}:$(get_golibdir_gopath)" GOROOT="${WORKDIR}/goroot"
        cp -sR "${EPREFIX}"/usr/lib/go "${GOROOT}" || die
 
        # Use latest versions of some packages, in case of incompatible