net-libs/libtrace: Version 4.0.9_p1
authorJeroen Roovers <jer@gentoo.org>
Tue, 16 Jul 2019 04:46:47 +0000 (06:46 +0200)
committerJeroen Roovers <jer@gentoo.org>
Tue, 16 Jul 2019 05:10:22 +0000 (07:10 +0200)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-libs/libtrace/Manifest
net-libs/libtrace/files/libtrace-4.0.9_p1-tinfo.patch [new file with mode: 0644]
net-libs/libtrace/libtrace-4.0.9_p1.ebuild [new file with mode: 0644]

index 33319711bafe266846c2d991cfa188294a254e6b..1a4af61f679261663f9d2b31044cf9c69593206a 100644 (file)
@@ -1,3 +1,4 @@
 DIST libtrace-4.0.6.tar.gz 969315 BLAKE2B 812100d7f0fe3def44404372c7b2287a2a9c9b3831cc2e3dee30cff0946d959089d44f201ba74aba57246242153e634806d899a108e18f195f5b6bfde8c0043c SHA512 8f888f57e4436d1aa7fc030212f7b356c58848151873569aa372c6cbcf62c5dd1ece4ecc5a98f6dbe8dc84a39d19abcbe42ff240282054b45cfce0c8ba048f16
 DIST libtrace-4.0.7.tar.gz 992013 BLAKE2B 24f2f684f58eb197ab7f117a5c2c97c0744b4ddfc210088058440148773066e64414766f7e1296c5520345b2a18f2b420215521ee169c74537f2f3ead92c9503 SHA512 3cfc2a47c7402e9ddd3821a7a435edfbb27b718c656400283fd5fa6f4137ede4acefbbd0390aab68e4140a6eb9f93b8df6726df484a79749798302ed3ae5165d
 DIST libtrace-4.0.8.tar.gz 1000829 BLAKE2B 943c3f800045c93880657e96173de0eff6ecbaab5ba22e8f29ad35363a3bdbb88a81d5c8c98e2750caff2cbe1b4590dd18bf924cc0520b041e54c1e17b8eb290 SHA512 10179a19c03d13451b088cd0678718bec3e3be2355c561d289a88457c7819a790c28094f7c3d95143bd3f16260f91fb6df465429375c7625d2ca0c696204de3b
+DIST libtrace-4.0.9_p1.tar.gz 1853724 BLAKE2B 2c2c8f44c5dea7c5acb3c3035cf8f749f1f33b03dd20675062718176ed26cba16c91f67df39512fb369896798edbe3f48e5624c72229bd00fc845712f8faf3cb SHA512 aa9e15322e507e01d9b51f6945772deba7673816c62546de30539792d7353b31235ae97866637f84969582e7300b634d080ba29a8cb088f5304a438e79357e57
diff --git a/net-libs/libtrace/files/libtrace-4.0.9_p1-tinfo.patch b/net-libs/libtrace/files/libtrace-4.0.9_p1-tinfo.patch
new file mode 100644 (file)
index 0000000..e79f7cf
--- /dev/null
@@ -0,0 +1,30 @@
+--- a/tools/tracetop/Makefile.am
++++ b/tools/tracetop/Makefile.am
+@@ -6,6 +6,6 @@
+ include ../Makefile.tools
+ tracetop_SOURCES = tracetop.cc
+-tracetop_LDADD = -lncurses 
++tracetop_LDADD = @ncurses_LIBS@
+ tracetop_CPPFLAGS = -fno-strict-aliasing $(AM_CFLAGS)
+ endif
+--- a/configure.in
++++ b/configure.in
+@@ -79,6 +79,8 @@
+ AC_CHECK_PROGS(YACC, 'bison -y' byacc yacc) 
+ AM_PROG_LEX
++PKG_PROG_PKG_CONFIG
++
+ # All our source files for function replacements are in lib/
+ AC_CONFIG_LIBOBJ_DIR(lib)
+@@ -645,6 +663,8 @@
+       fi
+ fi
++PKG_CHECK_MODULES(ncurses,ncurses,have_ncurses=yes,have_ncurses=no)
++
+ AC_ARG_WITH([ncurses],
+       AC_HELP_STRING([--with-ncurses], [build tracetop (requires ncurses)]))
diff --git a/net-libs/libtrace/libtrace-4.0.9_p1.ebuild b/net-libs/libtrace/libtrace-4.0.9_p1.ebuild
new file mode 100644 (file)
index 0000000..1c1a3c5
--- /dev/null
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="A library and tools for trace processing"
+HOMEPAGE="https://research.wand.net.nz/software/libtrace.php"
+SRC_URI="https://github.com/${PN^}Team/${PN}/archive//${PV/_p/-}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc ncurses numa static-libs"
+
+RDEPEND="
+       >=net-libs/libpcap-0.8
+       dev-libs/libyaml
+       dev-libs/openssl:0=
+       net-libs/wandio
+       ncurses? ( sys-libs/ncurses:0= )
+       numa? ( sys-process/numactl )
+"
+DEPEND="
+       ${RDEPEND}
+       app-doc/doxygen
+       sys-devel/flex
+       virtual/pkgconfig
+       virtual/yacc
+"
+PATCHES=(
+               "${FILESDIR}"/${PN}-3.0.20-autoconf-1.13.patch
+               "${FILESDIR}"/${PN}-4.0.0-no-examples.patch
+               "${FILESDIR}"/${PN}-4.0.0-with-numa.patch
+               "${FILESDIR}"/${PN}-4.0.9_p1-tinfo.patch
+)
+S=${WORKDIR}/${P/_p/-}
+
+src_prepare() {
+cp -av configure.in{,.orig} || die
+       default
+
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               $(use_enable static-libs static) \
+               $(use_with ncurses) \
+               $(use_with numa) \
+               --with-man
+}
+
+src_install() {
+       default
+
+       use doc && dodoc -r docs/doxygen/html
+
+       find "${D}" -name "*.la" -delete || die
+}