dev-perl/Audio-WMA: -r bump for EAPI7
authorKent Fredric <kentnl@gentoo.org>
Wed, 29 Apr 2020 12:34:25 +0000 (00:34 +1200)
committerKent Fredric <kentnl@gentoo.org>
Wed, 29 Apr 2020 12:34:41 +0000 (00:34 +1200)
- EAPI7
- Use patch instead of sed
- Parallel tests
- Removed unneeded variable assignments

Package-Manager: Portage-2.3.97, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/Audio-WMA/Audio-WMA-1.300.0-r1.ebuild [new file with mode: 0644]
dev-perl/Audio-WMA/files/Audio-WMA-1.3-no-dot-inc.patch [new file with mode: 0644]

diff --git a/dev-perl/Audio-WMA/Audio-WMA-1.300.0-r1.ebuild b/dev-perl/Audio-WMA/Audio-WMA-1.300.0-r1.ebuild
new file mode 100644 (file)
index 0000000..d19ed44
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_VERSION=1.3
+DIST_AUTHOR=DANIEL
+inherit perl-module
+
+DESCRIPTION="extension for reading WMA/ASF metadata"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PERL_RM_FILES=(
+       "t/pod.t"
+       "t/pod-coverage.t"
+)
+PATCHES=(
+       "${FILESDIR}/${PN}-1.3-no-dot-inc.patch"
+)
diff --git a/dev-perl/Audio-WMA/files/Audio-WMA-1.3-no-dot-inc.patch b/dev-perl/Audio-WMA/files/Audio-WMA-1.3-no-dot-inc.patch
new file mode 100644 (file)
index 0000000..7141ffd
--- /dev/null
@@ -0,0 +1,23 @@
+From 59f5c5d6f302c3cacb212048cb7c30b727e03d91 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Thu, 30 Apr 2020 00:11:42 +1200
+Subject: Include '.' in @INC on Perl 5.28+
+
+---
+ Makefile.PL | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index e607505..51add3f 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,5 +1,5 @@
+ # $Id: Makefile.PL 10 1998-12-16 23:02:45Z daniel $
+-
++use lib '.';
+ use inc::Module::Install;
+ name('Audio-WMA');
+-- 
+2.26.2
+