dev-libs/leatherman: 1.11.0 stable amd64/x86 with cleanup
authorMatthew Thode <prometheanfire@gentoo.org>
Thu, 23 Apr 2020 19:31:21 +0000 (14:31 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Thu, 23 Apr 2020 19:36:35 +0000 (14:36 -0500)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-libs/leatherman/Manifest
dev-libs/leatherman/leatherman-1.10.0.ebuild [deleted file]
dev-libs/leatherman/leatherman-1.11.0.ebuild

index 65be3db4fe8d66cff1b8c9a2ea75b78fae9ab464..7c2b6547dd13dc0e030b9b75ece3c99f9644f5ec 100644 (file)
@@ -1,3 +1,2 @@
-DIST leatherman-1.10.0.tar.gz 815748 BLAKE2B de4ff5e60fbdd80a247498e831203aad7efbb8857c8d307f0ac2c2f19fdf5ba3d953cb4910db0267a303b13bd54bf763034ca8b342a820fa8e28a2c013267149 SHA512 66d630980db7a8e5eb394c07d4a8221169271af1eabfceec107343b6c3afddde04c7cadd72b0d8b89327c46b7127dfdf01fa54938a3bf1b44892020a4e7ea209
 DIST leatherman-1.11.0.tar.gz 815946 BLAKE2B 73afb7c517ea93d0c3dc1c88adb3e5041c764bbfb223357b14a6a3f864ff614d178e7a71293eb533f09013fe3f64d5afe40c9404882d2fe6836da7322e869d8f SHA512 0cbc558ba6976d4f14947efbc59e2ebc306a8c7e4590a22fa2e2f044b37ffd8804dbabaf96c599c47394fd9379f2de1330ce5282237b5009730d8d3b87349ae5
 DIST leatherman-1.3.0.tar.gz 434229 BLAKE2B e0c19bca2378afc4928554ac0862543504ba725aadc6cffd78220f7f7f1b725cad960fc6d9fdd2d54a43c233b35959ebcb9c71d1191a5535703599fa32e3301e SHA512 5e06be7add652f69b0d4a8d778e33dfb68183c4d598217cc6542d2431f7984f0af989c27bd69e89b77ab03d6dd2adab9d70f68cd87dae20d8e24ae05923fbe9b
diff --git a/dev-libs/leatherman/leatherman-1.10.0.ebuild b/dev-libs/leatherman/leatherman-1.10.0.ebuild
deleted file mode 100644 (file)
index 1421317..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake-utils multilib
-
-DESCRIPTION="A C++ toolkit"
-HOMEPAGE="https://github.com/puppetlabs/leatherman"
-SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-IUSE="debug static-libs test"
-RESTRICT="!test? ( test )"
-KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc x86"
-SLOT="0/${PV}"
-
-RDEPEND="net-misc/curl"
-DEPEND=">=dev-libs/boost-1.54:=[nls]
-       net-misc/curl
-       >=sys-devel/gcc-4.8:*"
-
-PATCHES=( "${FILESDIR}"/portage-sandbox-test-fix.patch )
-
-src_prepare() {
-       sed -i 's/\-Werror\ //g' "cmake/cflags.cmake" || die
-       cmake-utils_src_prepare
-}
-
-src_configure() {
-       local mycmakeargs=(
-               -DCMAKE_VERBOSE_MAKEFILE=ON
-               -DCMAKE_BUILD_TYPE=None
-       )
-       if ! use static-libs; then
-               mycmakeargs+=(
-                       -DLEATHERMAN_SHARED=ON
-               )
-       else
-               mycmakeargs+=(
-                       -DLEATHERMAN_SHARED=OFF
-               )
-       fi
-       if use debug; then
-               mycmakeargs+=(
-                 -DCMAKE_BUILD_TYPE=Debug
-               )
-       fi
-       cmake-utils_src_configure
-}
-
-src_test() {
-       "${WORKDIR}/${P}"_build/bin/leatherman_test
-}
-
-src_install() {
-       cmake-utils_src_install
-}
index aef4cd92309564233b426e9119f337de94a0393c..1421317e76f8a3b5172fcfd03611af145b6a669e 100644 (file)
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
 LICENSE="Apache-2.0"
 IUSE="debug static-libs test"
 RESTRICT="!test? ( test )"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc x86"
 SLOT="0/${PV}"
 
 RDEPEND="net-misc/curl"