dev-python/rfc3986: 1.2.0 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 9 Apr 2019 05:27:55 +0000 (00:27 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 9 Apr 2019 07:05:04 +0000 (02:05 -0500)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/rfc3986/Manifest
dev-python/rfc3986/rfc3986-1.2.0.ebuild [new file with mode: 0644]

index 3736309b482ebd685bfb9c46687a9965d67f66b1..56dc4597b99b4dd8eac69db251c8b0548a5e72e0 100644 (file)
@@ -1,3 +1,4 @@
 DIST rfc3986-0.3.1.tar.gz 21591 BLAKE2B b24500baf27e4f17d22dbeb839262edb11b1c8c54ddd29782c2f4d83b5322e30f8800122349c9da0787f07c94e212616bbaace3b1d3bb1b2a5205aeba55355b3 SHA512 47c0cff5b67de5cc54ce3a24eb6d192a8b1414f5bb25e54056561fc0394058ec94853e62b9495dd72e15074921b66153279d4dffd1c199e252d569646a34aaed
 DIST rfc3986-0.4.1.tar.gz 22354 BLAKE2B db2a7edefa89fd3780721904c5e1b623d34dea5e8913c606336771d22f03c258f0a3cd3b71f42db6a6f2065bb055cf6938c10f166730953fe78cdc50dd0f148a SHA512 a4731206a4179d3970fcf9c21405f7e9686268ef3610ab5ca2413a867d83b83188c0efd5958b0b4ba8fc4076da9bc0cf18aef774213a1b58fc42bfc8a6d5dd92
 DIST rfc3986-1.1.0.tar.gz 39381 BLAKE2B cb890ae46c1428ddca1aed4a49660e2620659e7af64dbdb22c2514323ede374c28bbbd8401a5b4db257ba47e617ad7e8ae486f751fd4a7580808c68ff289ec13 SHA512 5e43ca7df586011900d2f01edfb20388598f77218e5a63904557bec0f1d0cb0a35f4980014de9c943ecc43a5a7ab3f7b815fbcfc9318e494c24a14fed2d1fac6
+DIST rfc3986-1.2.0.tar.gz 40162 BLAKE2B d51db37285366fdc7a6d25632afe440bbcdf4fbca46488082286824f046cfd81129b8f0e0695f986120276cf446dde5751dc52ebeb5f2f61f60c5acb92f2da1a SHA512 b88bdc47fa2daa6a9ffc339b1b997a85d0c8b3bf3ab271554e2a1a684c0394370e9cba07a82a542f39533a4c8cae69414234545db6caa2508e0ee7e7f8bdff3d
diff --git a/dev-python/rfc3986/rfc3986-1.2.0.ebuild b/dev-python/rfc3986/rfc3986-1.2.0.ebuild
new file mode 100644 (file)
index 0000000..0103ac5
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3)
+
+inherit distutils-r1
+
+DESCRIPTION="Validating URI References per RFC 3986"
+HOMEPAGE="https://tools.ietf.org/html/rfc3986
+       https://github.com/sigmavirus24/rfc3986
+       https://rfc3986.rtfd.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND=""
+
+python_test() {
+       py.test -vv || die
+}