Version bump to 2.6.14, thanks to Dave Liefbroer, fixes bug #135879
authorTom Knight <tomk@gentoo.org>
Sat, 17 Jun 2006 10:07:38 +0000 (10:07 +0000)
committerTom Knight <tomk@gentoo.org>
Sat, 17 Jun 2006 10:07:38 +0000 (10:07 +0000)
Package-Manager: portage-2.0.54

dev-php/smarty/ChangeLog
dev-php/smarty/Manifest
dev-php/smarty/files/digest-smarty-2.6.14 [new file with mode: 0644]
dev-php/smarty/smarty-2.6.14.ebuild [new file with mode: 0644]

index c9e8e0c964ba681dca4a07375833dd08844a8ed3..4ab91e9a7b32de45fa953ee8f91dc07a7863f70c 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for dev-php/smarty
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.57 2006/05/31 22:23:50 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.58 2006/06/17 10:07:38 tomk Exp $
+
+*smarty-2.6.14 (17 Jun 2006)
+
+  17 Jun 2006; Tom Knight <tomk@gentoo.org> +smarty-2.6.14.ebuild:
+  Version bump to 2.6.14, thanks to Dave Liefbroer, fixes bug #135879
 
   31 May 2006; Guy Martin <gmsoft@gentoo.org> smarty-2.6.13.ebuild:
   Stable on hppa.
index a57b34238fab7b64b8885dce370c38748e1e9a1e..024d40c23feff6245cd9f71ad831842921d4555b 100644 (file)
@@ -1,4 +1,6 @@
-MD5 59803e9316082eae69c799647c86ddc5 ChangeLog 7180
+MD5 fdd82838640f012a50bc928cbc52987c ChangeLog 7346
 MD5 aba467f36d22bb04d321841b6b586c20 files/digest-smarty-2.6.13 241
+MD5 20eda70f75444f1e7449224fbee38037 files/digest-smarty-2.6.14 65
 MD5 614fc58a3eb857c656b39f39e330a79e metadata.xml 245
 MD5 cdafddc45ba08dbb8bbf4518c77868cf smarty-2.6.13.ebuild 1502
+MD5 3586e77a9d6e688569fdf5e6e1014977 smarty-2.6.14.ebuild 1561
diff --git a/dev-php/smarty/files/digest-smarty-2.6.14 b/dev-php/smarty/files/digest-smarty-2.6.14
new file mode 100644 (file)
index 0000000..76820e9
--- /dev/null
@@ -0,0 +1 @@
+MD5 9186796ddbc29191306338dea9d632a0 Smarty-2.6.14.tar.gz 144986
diff --git a/dev-php/smarty/smarty-2.6.14.ebuild b/dev-php/smarty/smarty-2.6.14.ebuild
new file mode 100644 (file)
index 0000000..4377abd
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-2.6.14.ebuild,v 1.1 2006/06/17 10:07:38 tomk Exp $
+
+inherit php-lib-r1
+
+DESCRIPTION="A template engine for PHP."
+HOMEPAGE="http://smarty.php.net/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( dev-php/smarty-docs )"
+
+MY_P="Smarty-${PV}"
+SRC_URI="http://smarty.php.net/distributions/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+need_php_by_category
+
+src_install() {
+       dodoc-php BUGS ChangeLog FAQ NEWS QUICK_START README RELEASE_NOTES TODO
+       php-lib-r1_src_install ./libs `find ./libs -type f -print | sed -e "s|./libs||g"`
+}
+
+pkg_postinst() {
+       einfo "${PHP_LIB_NAME} has been installed in /usr/share/php/${PHP_LIB_NAME}/."
+       einfo "To use it in your scripts, either"
+       einfo "1. define('SMARTY_DIR', \"/usr/share/php/${PHP_LIB_NAME}/\") in your scripts, or"
+       einfo "2. add '/usr/share/php/${PHP_LIB_NAME}/' to the 'include_path' variable in your"
+       einfo "php.ini file under /etc/php/SAPI (where SAPI is one of apache-php[45],"
+       einfo "cgi-php[45] or cli-php[45])."
+       echo
+       einfo "If you're upgrading from a previous version make sure to clear out your"
+       einfo "templates_c and cache directories as some include paths have changed!"
+       echo
+       einfo "The Smarty include directory has changed in 2.6.12 from /usr/share/php/Smarty/"
+       einfo "to /usr/share/php/${PHP_LIB_NAME}/ you will need to change your SMARTY_DIR or"
+       einfo "include_path accordingly."
+}