use games_get_libdir
authorTristan Heaven <tristan@gentoo.org>
Mon, 9 Apr 2007 17:57:36 +0000 (17:57 +0000)
committerTristan Heaven <tristan@gentoo.org>
Mon, 9 Apr 2007 17:57:36 +0000 (17:57 +0000)
Package-Manager: portage-2.1.2.3

games-fps/aaquake2/aaquake2-0.1.ebuild
games-fps/doomsday/doomsday-1.9.0_beta5.ebuild
games-fps/nprquake-sdl/nprquake-sdl-1-r1.ebuild
games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild
games-fps/quake2-icculus/quake2-icculus-0.16.1.ebuild

index 0d88758bea82d4a9baed704410bc702e0581e6a9..bb95d0e78fc28e70086622b797a972b7f0e945c2 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/aaquake2/aaquake2-0.1.ebuild,v 1.9 2006/05/05 20:09:32 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/aaquake2/aaquake2-0.1.ebuild,v 1.10 2007/04/09 17:50:11 nyhm Exp $
 
 inherit eutils games
 
@@ -22,14 +22,18 @@ S=${WORKDIR}/quake2-3.21/linux
 
 src_unpack() {
        unpack ${A}
-       cd "${WORKDIR}/quake2-3.21"
-       epatch "${FILESDIR}"/${PV}-gentoo.patch \
-               "${FILESDIR}/${P}"-gcc41.patch
+       cd "${WORKDIR}"/quake2-3.21
+       epatch \
+               "${FILESDIR}"/${PV}-gentoo.patch \
+               "${FILESDIR}"/${P}-gcc41.patch
        cd linux
        sed -i \
-               -e "s:GENTOO_DIR:${GAMES_LIBDIR}/${PN}:" sys_linux.c
+               -e "s:GENTOO_DIR:$(games_get_libdir)/${PN}:" sys_linux.c \
+               || die "sed failed"
        sed -i \
-               -e "s:/etc/quake2.conf:${GAMES_SYSCONFDIR}/${PN}.conf:" sys_linux.c vid_so.c
+               -e "s:/etc/quake2.conf:${GAMES_SYSCONFDIR}/${PN}.conf:" \
+               sys_linux.c vid_so.c \
+               || die "sed failed"
 }
 
 src_compile() {
@@ -43,20 +47,18 @@ src_compile() {
 src_install() {
        cd release*
 
-       exeinto ${GAMES_LIBDIR}/${PN}
-       doexe gamei386.so ref_softaa.so || die
-       dosym ref_softaa.so ${GAMES_LIBDIR}/${PN}/ref_softx.so
-       dosym ref_softaa.so ${GAMES_LIBDIR}/${PN}/ref_soft.so
-       exeinto ${GAMES_LIBDIR}/${PN}/ctf
-       doexe ctf/gamei386.so || die
+       exeinto "$(games_get_libdir)"/${PN}
+       doexe gamei386.so ref_softaa.so || die "doexe failed"
+       dosym ref_softaa.so "$(games_get_libdir)"/${PN}/ref_softx.so
+       dosym ref_softaa.so "$(games_get_libdir)"/${PN}/ref_soft.so
+       exeinto "$(games_get_libdir)"/${PN}/ctf
+       doexe ctf/gamei386.so || die "doexe failed"
 
-       newgamesbin quake2 aaquake2 || die
+       newgamesbin quake2 aaquake2 || die "newgamesbin failed"
 
-       dodir ${GAMES_DATADIR}/quake2
-
-       insinto ${GAMES_SYSCONFDIR}
-       echo ${GAMES_LIBDIR}/${PN} > ${PN}.conf
-       doins ${PN}.conf
+       insinto "${GAMES_SYSCONFDIR}"
+       echo "$(games_get_libdir)"/${PN} > ${PN}.conf
+       doins ${PN}.conf || die "doins failed"
 
        prepgamesdirs
 }
index 0ed3e6cef05d6972671681efb097692e2b65f3fd..35bbb29e9032abd7e0af99593905f6715a45e4d5 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/doomsday/doomsday-1.9.0_beta5.ebuild,v 1.2 2007/03/13 01:29:19 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doomsday/doomsday-1.9.0_beta5.ebuild,v 1.3 2007/04/09 17:52:06 nyhm Exp $
 
 inherit toolchain-funcs games
 
@@ -33,7 +33,7 @@ src_compile() {
                -DCMAKE_INSTALL_PREFIX=/usr \
                -Ddatadir="${GAMES_DATADIR}"/${PN} \
                -Dbindir="${GAMES_BINDIR}" \
-               -Dlibdir="${GAMES_LIBDIR}" \
+               -Dlibdir="$(games_get_libdir)" \
                $(use openal && echo -DBUILDOPENAL=1) \
                ../ || die "cmake failed"
        emake || die "emake failed"
index 331502ddc9b51b2cd7d191a8664d14009b1dcf28..34d7290489057e744f52c5756541a7681c461542 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/nprquake-sdl/nprquake-sdl-1-r1.ebuild,v 1.11 2007/03/12 14:44:51 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/nprquake-sdl/nprquake-sdl-1-r1.ebuild,v 1.12 2007/04/09 17:54:20 nyhm Exp $
 
 inherit eutils games
 
@@ -27,7 +27,7 @@ src_unpack() {
 
 src_compile() {
        make \
-               GENTOO_LIBDIR="${GAMES_LIBDIR}/${PN}" \
+               GENTOO_LIBDIR="$(games_get_libdir)/${PN}" \
                GENTOO_DATADIR="${GAMES_DATADIR}/quake1" \
                OPTFLAGS="${CFLAGS}" \
                release \
@@ -38,9 +38,9 @@ src_install() {
        dodoc README CHANGELOG
        newgamesbin NPRQuakeSrc/release*/bin/* nprquake-sdl \
                || die "newgamesbin failed"
-       dodir "${GAMES_LIBDIR}/${PN}"
-       cp -r build/* "${D}/${GAMES_LIBDIR}/${PN}/" || die "cp failed"
-       cd "${D}/${GAMES_LIBDIR}/${PN}"
+       dodir "$(games_get_libdir)/${PN}"
+       cp -r build/* "${D}/$(games_get_libdir)/${PN}/" || die "cp failed"
+       cd "${D}/$(games_get_libdir)/${PN}"
        mv dr_default.so default.so
        ln -s sketch.so dr_default.so
        prepgamesdirs
index 479f06230b401d5250b70bdd6e98066b1564244a..6f3a487dd38757551167d8610f894dce3fc32197 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild,v 1.5 2007/03/13 01:30:25 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild,v 1.6 2007/04/09 17:57:36 nyhm Exp $
 
 inherit eutils toolchain-funcs games
 
@@ -133,7 +133,7 @@ src_compile() {
                        BUILD_ALSA=$(yesno alsa) \
                        SDLDIR=/usr/lib \
                        DEFAULT_BASEDIR="${GAMES_DATADIR}/quake2" \
-                       DEFAULT_LIBDIR="${GAMES_LIBDIR}/${PN}${libsuffix}" \
+                       DEFAULT_LIBDIR="$(games_get_libdir)/${PN}${libsuffix}" \
                        OPT_CFLAGS="${CFLAGS}" \
                        CC="$(tc-getCC)" \
                        || die "make failed"
@@ -149,8 +149,8 @@ src_compile() {
 }
 
 src_install() {
-       local q2dir=${GAMES_LIBDIR}/${PN}
-       local q2maxdir=${GAMES_LIBDIR}/${PN}-qmax
+       local q2dir=$(games_get_libdir)/${PN}
+       local q2maxdir=$(games_get_libdir)/${PN}-qmax
 
        dodoc readme.txt README TODO "${FILESDIR}"/README-postinstall
 
index 6d0959eafb03210a2d24381c3547df46722e2610..2f7baf782f56b47ef2ea0193b7e014da5aff26af 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/quake2-icculus-0.16.1.ebuild,v 1.18 2007/03/13 01:30:25 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/quake2-icculus-0.16.1.ebuild,v 1.19 2007/04/09 17:57:36 nyhm Exp $
 
 inherit eutils toolchain-funcs games
 
@@ -112,7 +112,7 @@ src_compile() {
                        BUILD_ALSA=$(yesno alsa) \
                        SDLDIR=/usr/lib \
                        DEFAULT_BASEDIR="${GAMES_DATADIR}/quake2" \
-                       DEFAULT_LIBDIR="${GAMES_LIBDIR}/${PN}${libsuffix}" \
+                       DEFAULT_LIBDIR="$(games_get_libdir)/${PN}${libsuffix}" \
                        OPT_CFLAGS="${CFLAGS}" \
                        CC="$(tc-getCC)" \
                        || die "make failed"
@@ -128,8 +128,8 @@ src_compile() {
 }
 
 src_install() {
-       local q2dir=${GAMES_LIBDIR}/${PN}
-       local q2maxdir=${GAMES_LIBDIR}/${PN}-qmax
+       local q2dir=$(games_get_libdir)/${PN}
+       local q2maxdir=$(games_get_libdir)/${PN}-qmax
 
        dodoc readme.txt README TODO "${FILESDIR}"/README-postinstall