dev-python/nose2: Drop 0.6.5
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 8 Dec 2019 12:02:17 +0000 (13:02 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 8 Dec 2019 12:04:06 +0000 (13:04 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-python/nose2/Manifest
dev-python/nose2/nose2-0.6.5.ebuild [deleted file]

index 1c8a420e70fb32fbdc4a92cfc39d8149a90df61e..53dfa03171c4c395cadab041caa6ce2f62bc63c2 100644 (file)
@@ -1,2 +1 @@
-DIST nose2-0.6.5.tar.gz 134808 BLAKE2B 5f094d537ff7c48b7bfaf139b4c96a93875013ca5663d1e5b3feec543e7efd55335488321bcdd5752529cb36685dd28c91bd29665aed9e5f58fef837e5e2944b SHA512 fc84aa19d486ff1441dd43666182212e4a05b3be054f3c8967e36e624c08ee6eb10b01bba45b5f5dbbd38cfd057d53877e0bc0d9aba59b842688a5d4ec944b40
 DIST nose2-0.9.1.tar.gz 152411 BLAKE2B 39f2d992e5cab4b9e5cd4401ea9285884eeeac7d2e126b5aad5582186efa0f325139480a446950019e91a376b5992fea106064e5170c9ea7961f128b895a335c SHA512 48cfe3956a3cb696e344ea03e5e0ac8d52831b8272b7cad2bdee34681d1e4e7968fe9da9b71cc9db40b6edf289509c2af766e73611f3a6f23ebd5062f4d52c9e
diff --git a/dev-python/nose2/nose2-0.6.5.ebuild b/dev-python/nose2/nose2-0.6.5.ebuild
deleted file mode 100644 (file)
index 4e7c882..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="nose2 is the next generation of nicer testing for Python"
-HOMEPAGE="https://github.com/nose-devs/nose2"
-SRC_URI="https://github.com/nose-devs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc"
-
-CDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       >=dev-python/six-1.1[${PYTHON_USEDEP}]
-"
-DEPEND="
-       ${CDEPEND}
-       doc? ( >=dev-python/sphinx-1.0.5[${PYTHON_USEDEP}] )
-"
-RDEPEND="
-       ${CDEPEND}
-       >=dev-python/cov-core-1.12[${PYTHON_USEDEP}]
-"
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       "${PYTHON}" -m nose2.__main__ || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-
-       distutils-r1_python_install_all
-}