dev-python/pygresql: Clean old up
authorMichał Górny <mgorny@gentoo.org>
Fri, 5 Jan 2018 22:11:29 +0000 (23:11 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 5 Jan 2018 23:19:13 +0000 (00:19 +0100)
dev-python/pygresql/Manifest
dev-python/pygresql/pygresql-4.2.ebuild [deleted file]

index 44682f6f666339f51b4800a5beda7e238e80175c..398f8c971d4e882bcf966c672b832898efd3bd93 100644 (file)
@@ -1,3 +1,2 @@
 DIST PyGreSQL-4.1.1.tgz 100883 BLAKE2B 8b3876803b61fde62a248cf6499b9396a16069fd5cebad8f17ca942990a5502a702081b395745863d54b304d426455dd94d816caea9e09809a7ff0ca1b4903b0 SHA512 4b37c56f2112471aa5f3003a1d867382ce1b7510afa0963f0ceeb2f8175ca601bb5bade9ea2038d44a1041f12233e364f138a635bb7b353d0a82aeb7d9d49b7f
-DIST PyGreSQL-4.2.zip 1377728 BLAKE2B bca6846881645e9ef9b29e2960b9db99b1029754a88a570b95a83cf7afba992e85d801092664239e3cc3a07063627ef46551cc00851631898a75d12641255b44 SHA512 84044480c3f25548137240ac999334546b87987ac6c601608bcae057cf93567f0eb24e343f6ee214ea87e09ac6bd5ce80cfeb5f75deb7896e87b001a2099c78f
 DIST PyGreSQL-5.0.4.tar.gz 637569 BLAKE2B 3f7bddb8b5e455ca4f181d254d4d125b89a64d7aaa1440b9ab5d916c395b9d93fc9814269992c134b6fd8a81f436752dbe4d7c06125e683a5257361d428c6a6f SHA512 f177ca3b023c007dafe80369b86a1742ff334137e493c3c19ac8bda0181d2543cd2431b8ab8d2d43f30d681121324bc4f236a9ebbddf1e927b071db7c9b34ea6
diff --git a/dev-python/pygresql/pygresql-4.2.ebuild b/dev-python/pygresql/pygresql-4.2.ebuild
deleted file mode 100644 (file)
index 2f8e16c..0000000
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-POSTGRES_COMPAT=( 9.{0,1,2,3,4,5} )
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-MY_P="PyGreSQL-${PV}"
-
-DESCRIPTION="A Python interface for the PostgreSQL database"
-HOMEPAGE="http://www.pygresql.org/"
-SRC_URI="mirror://pypi/P/PyGreSQL/${MY_P}.zip"
-
-LICENSE="POSTGRESQL"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
-IUSE="doc"
-
-DEPEND="|| (
-       dev-db/postgresql:9.5
-       dev-db/postgresql:9.4
-       dev-db/postgresql:9.3
-       dev-db/postgresql:9.2
-       dev-db/postgresql:9.1
-       dev-db/postgresql:9.0
-)"
-
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-# Verify that the currently selected PostgreSQL slot is set to one of
-# the slots defined in POSTGRES_COMPAT.
-postgres_check_slot() {
-       if ! declare -p POSTGRES_COMPAT &>/dev/null; then
-               die 'POSTGRES_COMPAT not declared.'
-       fi
-
-# Don't die because we can't run postgresql-config during pretend.
-[[ "$EBUILD_PHASE" = "pretend" && -z "$(which postgresql-config 2> /dev/null)" ]] \
-       && return 0
-
-       local res=$(echo ${POSTGRES_COMPAT[@]} \
-               | grep -c $(postgresql-config show 2> /dev/null) 2> /dev/null)
-
-       if [[ "$res" -eq "0" ]] ; then
-                       eerror "PostgreSQL slot must be set to one of: "
-                       eerror "    ${POSTGRES_COMPAT[@]}"
-                       return 1
-       fi
-
-       return 0
-}
-
-pkg_pretend() {
-       postgres_check_slot
-}
-
-pkg_setup() {
-       postgres_check_slot || die
-}
-
-python_install_all() {
-       local DOCS=( docs/*.rst )
-       distutils-r1_python_install_all
-
-       if use doc; then
-               insinto /usr/share/doc/${PF}/tutorial
-               doins tutorial/*
-               dohtml docs/*.{html,css}
-       fi
-}