dev-erlang/fast_tls: Version bump
authorHanno <hanno@gentoo.org>
Sat, 31 Aug 2019 14:18:55 +0000 (16:18 +0200)
committerHanno <hanno@gentoo.org>
Sat, 31 Aug 2019 14:19:22 +0000 (16:19 +0200)
Signed-off-by: Hanno Boeck <hanno@gentoo.org>
Package-Manager: Portage-2.3.74, Repoman-2.3.17

dev-erlang/fast_tls/Manifest
dev-erlang/fast_tls/fast_tls-1.1.2.ebuild [new file with mode: 0644]

index 0b1e670721453cabe89789f1a6e28720c6d8da9b..fda9a0dedc348276133083b72f3bb45dd7c1d038 100644 (file)
@@ -1 +1,2 @@
 DIST fast_tls-1.0.26.tar.gz 76348 BLAKE2B 3016d26724119a2b0b6e4ce9691ceeca7009ee758465f7d7203cab526c9cf588cefd859cb452d7f28877a2d3cf4eef26f9941bccb7aee4794006d9c0f4e8561e SHA512 3be4ed4a346c2d20f7a9d080a12e98fcf180c2f25df7a505a798ca8581aee74c4dc2f92b74c1a6866d6b13e65940cf0adfaff3cceccb0fe9fb3f375a3ebcfcd8
+DIST fast_tls-1.1.2.tar.gz 80657 BLAKE2B 44df81fca2e2a3dac8b4c9dac2506d313aea7d1a75a05b1cc1bd42e237c6ed951306e2acf7169538e3d0e68463fa8142f4d57776a8c86abdbd17f6973600f79e SHA512 79027ba6d80cb6b2bc0d6cd92d3889fa13e7ee746db20582517fc0ce36173b112805a94568a89d718166dfa4b41cd49bf8a6bc505979d4b25a389e87fdc3e4cb
diff --git a/dev-erlang/fast_tls/fast_tls-1.1.2.ebuild b/dev-erlang/fast_tls/fast_tls-1.1.2.ebuild
new file mode 100644 (file)
index 0000000..a51677b
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="TLS/SSL native driver for Erlang and Elixir"
+HOMEPAGE="https://github.com/processone/fast_tls"
+SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
+       -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+IUSE="libressl"
+
+DEPEND=">=dev-erlang/p1_utils-1.0.16
+       >=dev-lang/erlang-17.1
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGELOG.md README.md )