sys-cluster/corosync: drop invalid version check, bug #705276
authorSergei Trofimovich <slyfox@gentoo.org>
Tue, 5 May 2020 21:46:02 +0000 (22:46 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Tue, 5 May 2020 21:46:13 +0000 (22:46 +0100)
'if [[ ${REPLACING_VERSIONS} < 2.0 ]]; then' uses lexicographical
version compare. That should be ver_cmp version compare or similar.

As it's a guard against non-existent version let's just drop the ewarn.

Closes: https://bugs.gentoo.org/705276
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-cluster/corosync/corosync-2.3.5.ebuild
sys-cluster/corosync/corosync-2.4.2.ebuild

index 3e4bf6a0f565eed611812337a45762f58c25540e..3485dedb6bb126ca13849f11e4313f6d2617a706 100644 (file)
@@ -73,14 +73,3 @@ src_install() {
        use static-libs || rm -rf "${D}"/usr/$(get_libdir)/*.{,l}a || die
 
 }
-
-pkg_postinst() {
-       if [[ ${REPLACING_VERSIONS} < 2.0 ]]; then
-               ewarn "!! IMPORTANT !!"
-               ewarn " "
-               ewarn "Migrating from a previous version of corosync can be dangerous !"
-               ewarn " "
-               ewarn "Make sure you backup your cluster configuration before proceeding"
-               ewarn " "
-       fi
-}
index 49840bb0216f46aadd053960313cd7efbc01de15..bdea670c8da2ed5c2f6178b434024eb00d16948f 100644 (file)
@@ -69,14 +69,3 @@ src_install() {
        use static-libs || rm -rf "${D}"/usr/$(get_libdir)/*.{,l}a || die
 
 }
-
-pkg_postinst() {
-       if [[ ${REPLACING_VERSIONS} < 2.0 ]]; then
-               ewarn "!! IMPORTANT !!"
-               ewarn " "
-               ewarn "Migrating from a previous version of corosync can be dangerous !"
-               ewarn " "
-               ewarn "Make sure you backup your cluster configuration before proceeding"
-               ewarn " "
-       fi
-}