xfce-extra/xfce4-clipman-plugin: Bump to 1.4.4
authorMichał Górny <mgorny@gentoo.org>
Sun, 1 Mar 2020 19:06:50 +0000 (20:06 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 1 Mar 2020 19:08:15 +0000 (20:08 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
xfce-extra/xfce4-clipman-plugin/Manifest
xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.4.4.ebuild [new file with mode: 0644]

index 0af910ec5267a3b8aaef40bbec3bae6ac16317c2..69627ddf702f9c909e1d541a544d671eeb8adf0a 100644 (file)
@@ -1 +1,2 @@
 DIST xfce4-clipman-plugin-1.4.3.tar.bz2 492784 BLAKE2B f52dc92976e0b826b7aab2b8a3b9e099bb31e3d670911608d7a39c9805b011bb4c77db1fb01379e3244682a4bcefba617e246cc9ade50ecd275ea554d928385f SHA512 28bc8e2be8dd3eac13a7988b68933ce84dd8cc756f0a19636cd5850d6e36714a73ad9650a28ebfc54d9ad3adb23c242abf89806124b4e00fe7d1701be1b52414
+DIST xfce4-clipman-plugin-1.4.4.tar.bz2 460114 BLAKE2B c3a6d8a9a3f36367bddf3803b86dc4bd5bf2dff94d675695caf95010c563b96b69ce4015d83568e9500f8f5d579f41ef8c5ce94804ecd58baa04f7cc9aa54f16 SHA512 4cb798faab4efdc7a5013cffd06ce527efbda4ba5b96063734d261a864f22075a2d6dd1f79a33c8bdfb39ceea8f89af3daac023aaed8a5a386c70604e8a77965
diff --git a/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.4.4.ebuild b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.4.4.ebuild
new file mode 100644 (file)
index 0000000..d763b3d
--- /dev/null
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="A clipboard manager plug-in for the Xfce panel"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-clipman-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="qrcode"
+
+RDEPEND=">=dev-libs/glib-2.32:2=
+       >=x11-libs/gtk+-3.14:3=
+       x11-libs/libXtst:=
+       >=xfce-base/libxfce4ui-4.12:=
+       >=xfce-base/libxfce4util-4.12:=
+       >=xfce-base/xfce4-panel-4.12:=
+       >=xfce-base/xfconf-4.10:=
+       qrcode? ( >=media-gfx/qrencode-3.3.0:= )"
+DEPEND="${RDEPEND}
+       dev-util/intltool
+       sys-devel/gettext
+       virtual/pkgconfig
+       x11-base/xorg-proto"
+
+src_configure() {
+       local myconf=(
+               $(use_enable qrcode libqrencode)
+       )
+
+       econf "${myconf[@]}"
+}
+
+src_install() {
+       default
+
+       find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+}