Minor cleanup for the LIVEVCS.stable code.
authorZac Medico <zmedico@gentoo.org>
Sun, 28 Jan 2007 22:10:08 +0000 (22:10 -0000)
committerZac Medico <zmedico@gentoo.org>
Sun, 28 Jan 2007 22:10:08 +0000 (22:10 -0000)
svn path=/main/trunk/; revision=5821

bin/repoman

index 695141ca172e96096c23a5983ffc8c39016988ac..09a340f4e25c4cade29916245f7c4e7763c83482 100755 (executable)
@@ -1042,12 +1042,20 @@ for x in scanlist:
                Ebuilds that inherit a "Live" eclasss (darcs,subversion,git,cvs,etc..) should
                not be allowed to be marked stable
                """
-               if set(["darcs","cvs","subversion","git"]).intersection(myaux["INHERITED"].split()):
-                       bad_stable_keywords = [keyword for keyword in myaux["KEYWORDS"].split() if not keyword.startswith("~") and not keyword.startswith("-")]
+               if set(["darcs","cvs","subversion","git"]).intersection(
+                       myaux["INHERITED"].split()):
+                       bad_stable_keywords = []
+                       for keyword in myaux["KEYWORDS"].split():
+                               if not keyword.startswith("~") and \
+                                       not keyword.startswith("-"):
+                                       bad_stable_keywords.append(keyword)
+                               del keyword
                        if bad_stable_keywords:
                                stats["LIVEVCS.stable"] += 1
-                               fails["LIVEVCS.stable"].append(x+"/"+y+".ebuild with stable keywords:%s " % bad_stable_keywords)
-                       del bad_stable_keywords         
+                               fails["LIVEVCS.stable"].append(
+                                       x + "/" + y + ".ebuild with stable keywords:%s " % \
+                                               bad_stable_keywords)
+                       del bad_stable_keywords
 
                if "--ignore-arches" in myoptions:
                        arches = [[repoman_settings["ARCH"], repoman_settings["ARCH"],