media-video/subliminal: Call pytest directly
authorMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 08:41:10 +0000 (09:41 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 09:39:39 +0000 (10:39 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
media-video/subliminal/subliminal-2.0.5-r2.ebuild
media-video/subliminal/subliminal-2.0.5-r3.ebuild
media-video/subliminal/subliminal-9999.ebuild

index 563745b2e1c371034e7231ba9f3f5f0ba81ff31c..553544eeb7c5e96458484ed96a90e769152569de 100644 (file)
@@ -43,8 +43,6 @@ DEPEND="${RDEPEND}
                app-arch/unzip
                >=dev-python/vcrpy-1.6.1[${PYTHON_USEDEP}]
                dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-cov[${PYTHON_USEDEP}]
-               dev-python/pytest-runner[${PYTHON_USEDEP}]
                dev-python/sympy[${PYTHON_USEDEP}]
        )
 "
index d2167d8739afacf6350131d819ffed1c76de29bb..1f8be45ef01b5a51dc516e70e9c9aef05b705a64 100644 (file)
@@ -19,7 +19,6 @@ SRC_URI="
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="test"
 
 RDEPEND="
        >=dev-python/appdirs-1.3[${PYTHON_USEDEP}]
@@ -42,11 +41,7 @@ RDEPEND="
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
-               ${RDEPEND}
                app-arch/unzip
-               dev-python/pytest-cov[${PYTHON_USEDEP}]
-               dev-python/pytest-runner[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
                dev-python/sympy[${PYTHON_USEDEP}]
                >=dev-python/vcrpy-1.6.1[${PYTHON_USEDEP}]
        )
@@ -59,6 +54,8 @@ PATCHES=( "${FILESDIR}/${P}-add-missing-comma.patch" )
 
 S="${WORKDIR}/${PN}-${COMMIT_ID}"
 
+distutils_enable_tests pytest
+
 python_prepare_all() {
        # Disable code checkers as they require unavailable dependencies.
        sed -i -e 's/--\(pep8\|flakes\)//g' pytest.ini || die
@@ -74,7 +71,3 @@ python_prepare_all() {
 
        distutils-r1_python_prepare_all
 }
-
-python_test() {
-       esetup.py test
-}
index f729768f9ee6f1162d537e3624644ce6becd47bd..13b314d12fb2abbd77b36a46eb1f9fb225cdee9e 100644 (file)
@@ -17,8 +17,6 @@ SRC_URI="test? ( mirror://sourceforge/matroska/test_files/matroska_test_w1_1.zip
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS=""
-IUSE="test"
-RESTRICT="!test? ( test )"
 
 RDEPEND="
        >=dev-python/appdirs-1.3[${PYTHON_USEDEP}]
@@ -38,17 +36,16 @@ RDEPEND="
        >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
        >=dev-python/stevedore-1.0.0[${PYTHON_USEDEP}]
 "
-DEPEND="${RDEPEND}
+DEPEND="
        test? (
                app-arch/unzip
-               dev-python/pytest-cov[${PYTHON_USEDEP}]
-               dev-python/pytest-runner[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
                dev-python/sympy[${PYTHON_USEDEP}]
                >=dev-python/vcrpy-1.6.1[${PYTHON_USEDEP}]
        )
 "
 
+distutils_enable_tests pytest
+
 src_unpack() {
        default_src_unpack
        git-r3_src_unpack
@@ -69,7 +66,3 @@ python_prepare_all() {
 
        distutils-r1_python_prepare_all
 }
-
-python_test() {
-       esetup.py test
-}