dev-python/pycparser: Enforce regenerating tables
authorMichał Górny <mgorny@gentoo.org>
Sun, 27 Aug 2017 17:59:40 +0000 (19:59 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 27 Aug 2017 18:07:49 +0000 (20:07 +0200)
Remove the pregenerated tables provided in the distfile to force
regenerating them. Generate the tables for every Python implementation
separately to avoid incompatibility/underoptimization problems (tables
built by Python 3.5+ are incompatible with older Python versions that
have 100 group-in-regex limit).

dev-python/pycparser/pycparser-2.18-r1.ebuild [moved from dev-python/pycparser/pycparser-2.18.ebuild with 59% similarity]

similarity index 59%
rename from dev-python/pycparser/pycparser-2.18.ebuild
rename to dev-python/pycparser/pycparser-2.18-r1.ebuild
index 292106b4124e1444f035036ef5cfc19018b86d68..3fb094f6ff3fc557543708bcc0a0cf53888e2a91 100644 (file)
@@ -21,13 +21,28 @@ DEPEND="${RDEPEND}
        dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( dev-python/nose[${PYTHON_USEDEP}] )"
 
+python_prepare_all() {
+       # remove the original files to guarantee their regen
+       rm pycparser/{c_ast,lextab,yacctab}.py || die
+
+       # kill sys.path manipulations to force the tests to use built files
+       sed -i -e '/sys\.path/d' tests/*.py || die
+
+       distutils-r1_python_prepare_all
+}
+
 python_compile() {
        distutils-r1_python_compile
-       pushd "${BUILD_DIR}/lib/pycparser" > /dev/null || die
+
+       # note: tables built by py3.5+ are incompatible with older versions
+       # because of 100 group limit of 're' module -- just generate them
+       # separately optimized for each target instead
+       pushd "${BUILD_DIR}"/lib/pycparser > /dev/null || die
        "${PYTHON}" _build_tables.py || die
        popd > /dev/null || die
 }
 
 python_test() {
-       nosetests || die
+       # change workdir to avoid '.' import
+       nosetests -v -w tests || die
 }