dev-python/tvdb_api: add py3.7 & py3.8 & EAPI=7
authorMike Frysinger <vapier@gentoo.org>
Tue, 5 May 2020 20:54:11 +0000 (16:54 -0400)
committerMike Frysinger <vapier@gentoo.org>
Tue, 5 May 2020 20:54:38 +0000 (16:54 -0400)
Fixes: https://bugs.gentoo.org/719596
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
dev-python/tvdb_api/tvdb_api-2.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/tvdb_api/tvdb_api-2.0-r1.ebuild b/dev-python/tvdb_api/tvdb_api-2.0-r1.ebuild
new file mode 100644 (file)
index 0000000..4b2690e
--- /dev/null
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Python interface to thetvdb.com API"
+HOMEPAGE="https://github.com/dbr/tvdb_api"
+SRC_URI="mirror://pypi/t/${PN}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/requests-cache[${PYTHON_USEDEP}]"