dev-java/microba: Add resources (bug #586820), EAPI 6, clean up
authorJames Le Cuirot <chewi@gentoo.org>
Sun, 9 Jul 2017 22:22:15 +0000 (23:22 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Sun, 9 Jul 2017 22:22:47 +0000 (23:22 +0100)
Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-java/microba/microba-0.4.4.3-r1.ebuild [new file with mode: 0644]

diff --git a/dev-java/microba/microba-0.4.4.3-r1.ebuild b/dev-java/microba/microba-0.4.4.3-r1.ebuild
new file mode 100644 (file)
index 0000000..a29ff3d
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Swing components for date operations and palettes"
+HOMEPAGE="https://github.com/tdbear/microba"
+SRC_URI="https://github.com/tdbear/${PN}/archive/${PV}.zip -> ${P}.zip"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CP_DEPEND="dev-java/jgraph:0"
+
+RDEPEND="${CP_DEPEND}
+       >=virtual/jre-1.6"
+
+DEPEND="${CP_DEPEND}
+       >=virtual/jdk-1.6"
+
+S="${WORKDIR}/${P}"
+JAVA_SRC_DIR="src/main/java"
+
+DOCS=(
+       change.log.txt
+       readme.txt
+       README.md
+)
+
+src_compile() {
+       java-pkg-simple_src_compile
+       java-pkg_addres ${PN}.jar ${JAVA_SRC_DIR}
+}
+
+src_install() {
+       default
+       java-pkg-simple_src_install
+}