net-ftp/filezilla: Bump to version 3.38.0
authorLars Wendler <polynomial-c@gentoo.org>
Sat, 27 Oct 2018 00:38:50 +0000 (02:38 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Sat, 27 Oct 2018 00:38:50 +0000 (02:38 +0200)
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

net-ftp/filezilla/Manifest
net-ftp/filezilla/filezilla-3.38.0.ebuild [new file with mode: 0644]

index 57b9b1475480b5b79d7e9268c67e4b84e40f86c5..20b584cbb435fe5361f28858ded9d09ed927ac5d 100644 (file)
@@ -4,3 +4,4 @@ DIST FileZilla_3.35.2_src.tar.bz2 4968449 BLAKE2B 1c06b0a67177fc2b91e037eef02c08
 DIST FileZilla_3.36.0_src.tar.bz2 4981429 BLAKE2B f297671ead361b4b1b1063bca2c78ad1e8c029f9eb3eae2a6bd4bd56c794cfb4e9b70ee4cf9addda60635e12d7e37cf42b34763316d73beab37a24ab94eb03d8 SHA512 d5c9ebd49944b3f2b55f5b494113ffde13b61f5d98e3be0507731e0dfc0d18f1f36ec5d4bf0f9ce2bbcf9d9b91b92b93b192739fb89c99c6cced80e131b58322
 DIST FileZilla_3.37.1_src.tar.bz2 4981676 BLAKE2B 984cd603ccf7990380accc3301cc794873dd76c9360afe7393aba9153a124805f21f41148356bfb9012d28329c48bb0e1ce378cb81477b4be22522b0daf53646 SHA512 eb333c9bcf812f0aa6e299432b5df10930d0d764ac101e4a08c4eceffc3b08d34c5d193caa626d2ebb62c9ecb0ea2bb59c1ed5d90ff1b47f34e1741a788e9ab9
 DIST FileZilla_3.37.4_src.tar.bz2 4983335 BLAKE2B 16929caca3aabfdea406469a4128878f3cc48b347084d5d362ad206a7549be129195e8f111324b259e64d8e9324d9decd4bb51d088367fcaa560ec1feeb03570 SHA512 3f6697fd411b898f0db375bba7e6a34157c73274ee463832c38a4897240d990654c447baad8b0024492cb882106e7e63757d54401c487cfad96038d1f5eabfea
+DIST FileZilla_3.38.0_src.tar.bz2 4984596 BLAKE2B 19a462181ba6f1832302828e57e9892f3dbd00c1bd2e095e1f071df3c48a1eed82e7177b93f86e8860a53d42a34370c96d75932144d40cb464e37bebb4eb9c04 SHA512 68c6915b2ec1873a3168479d479d56663a906a6b4b40e10f863cbd4e7545add74591954972dbbf6bb22c6640878edc28433dc5f057d7351d5429710b51d83977
diff --git a/net-ftp/filezilla/filezilla-3.38.0.ebuild b/net-ftp/filezilla/filezilla-3.38.0.ebuild
new file mode 100644 (file)
index 0000000..1f2606a
--- /dev/null
@@ -0,0 +1,75 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER="3.0-gtk3"
+
+inherit autotools flag-o-matic gnome2-utils wxwidgets
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="https://filezilla-project.org/"
+SRC_URI="https://download.filezilla-project.org/client/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86"
+IUSE="dbus nls test"
+
+# pugixml 1.7 minimal dependency is for c++11 proper configuration
+RDEPEND=">=app-eselect/eselect-wxwidgets-0.7-r1
+       >=dev-libs/nettle-3.1:=
+       >=dev-db/sqlite-3.7
+       >=dev-libs/libfilezilla-0.15.0
+       >=dev-libs/pugixml-1.7
+       >=net-libs/gnutls-3.4.15
+       >=x11-libs/wxGTK-3.0.4:${WX_GTK_VER}[X]
+       x11-misc/xdg-utils
+       dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       >=sys-devel/libtool-1.4
+       nls? ( >=sys-devel/gettext-0.11 )
+       test? ( >=dev-util/cppunit-1.13.0 )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+DOCS=(AUTHORS ChangeLog NEWS )
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-3.22.1-debug.patch
+)
+
+pkg_pretend() {
+       if [[ ${MERGE_TYPE} != binary ]]; then
+               if ! test-flag-CXX -std=c++14; then
+                       eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
+                       eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
+                       eerror "to gcc-4.9 or an equivalent version supporting C++14."
+                       die "Currently active compiler does not support -std=c++14"
+               fi
+       fi
+}
+
+src_prepare() {
+       setup-wxwidgets
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf $(use_with dbus) $(use_enable nls locales) \
+               --with-pugixml=system \
+               --disable-autoupdatecheck
+}
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+}