fix #114316
authorBenedikt Boehm <hollow@gentoo.org>
Tue, 6 Jun 2006 11:05:47 +0000 (11:05 +0000)
committerBenedikt Boehm <hollow@gentoo.org>
Tue, 6 Jun 2006 11:05:47 +0000 (11:05 +0000)
Package-Manager: portage-2.1_rc3-r1

net-www/mod_encoding/ChangeLog
net-www/mod_encoding/files/digest-mod_encoding-20040616 [new file with mode: 0644]
net-www/mod_encoding/mod_encoding-20040616.ebuild [new file with mode: 0644]

index d0261ea6d7d16efcaa3a41d422cee120093fca2b..46dc620b35da2cfdc126381b33252fc4e63182b6 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for net-www/mod_encoding
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_encoding/ChangeLog,v 1.8 2006/06/04 19:40:08 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_encoding/ChangeLog,v 1.9 2006/06/06 11:05:47 hollow Exp $
+
+*mod_encoding-20040616 (06 Jun 2006)
+
+  06 Jun 2006; Benedikt Böhm <hollow@gentoo.org> -files/mod_encoding.conf,
+  +mod_encoding-20040616.ebuild:
+  fix #114316
 
   04 Jun 2006; Michael Stewart <vericgar@gentoo.org>
   -mod_encoding-20021209.ebuild:
diff --git a/net-www/mod_encoding/files/digest-mod_encoding-20040616 b/net-www/mod_encoding/files/digest-mod_encoding-20040616
new file mode 100644 (file)
index 0000000..499adda
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 5015b7a38e16be8534d2edcc8614d00e mod_encoding.c.apache2.20040616 16954
+RMD160 439b7a6debaa8df6dfb6a46b6498b800b3f7049c mod_encoding.c.apache2.20040616 16954
+SHA256 820765b97d83597666ba135a75eb69a1a813b2d871525dc18910e6f83423748a mod_encoding.c.apache2.20040616 16954
diff --git a/net-www/mod_encoding/mod_encoding-20040616.ebuild b/net-www/mod_encoding/mod_encoding-20040616.ebuild
new file mode 100644 (file)
index 0000000..d2dbec6
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_encoding/mod_encoding-20040616.ebuild,v 1.1 2006/06/06 11:05:47 hollow Exp $
+
+inherit apache-module
+
+DESCRIPTION="Apache module for non-ascii filename interoperability"
+HOMEPAGE="http://webdav.todo.gr.jp/"
+SRC_URI="http://webdav.todo.gr.jp/download/experimental/${PN}.c.apache2.${PV}"
+
+IUSE=""
+DEPEND=""
+KEYWORDS="~x86"
+LICENSE="as-is"
+SLOT="0"
+
+APACHE2_MOD_CONF="30_${PN}"
+APACHE2_MOD_DEFINE="ENCODING"
+
+need_apache2
+
+src_unpack() {
+       mkdir -p ${S} && cp ${DISTDIR}/${PN}.c.apache2.${PV} ${S}/${PN}.c || die
+       cd ${S} || die
+
+       sed -i -e "s:iconv_hook/iconv:iconv:" ${PN}.c || die
+}