dev-java/bcpkix: Clean up old.
authorPatrice Clement <monsieurp@gentoo.org>
Fri, 16 Oct 2015 08:20:04 +0000 (08:20 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Fri, 16 Oct 2015 08:20:04 +0000 (08:20 +0000)
Package-Manager: portage-2.2.20.1
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
dev-java/bcpkix/Manifest
dev-java/bcpkix/bcpkix-1.50.ebuild [deleted file]
dev-java/bcpkix/bcpkix-1.52.ebuild [deleted file]

index eb46a6c27a26cbfc7e70ed7b53af1cf1901e8960..96790d72153e15653f55bf092ac612ec1525ee00 100644 (file)
@@ -1,4 +1,2 @@
 DIST bcpkix-jdk15on-1.50-sources.jar 401716 SHA256 6ec7b485da90c07a45d71905a4ef9c3c5a50aa94904a66209d928efebce83105 SHA512 6dc6d63db649a94f54c7739144b4120db4255e0a0a713389d54fcd427b95a3ff5ec326ae066cb5aa8a6cf19ccb959cbb22f9f898d39bfe5bf8e20c4d9de6931c WHIRLPOOL 8523b5ba41ba9fba1988a9e8707921f46cea448acfb9fa277b85a454ed3072527b9fc992769b8d802b9cb821b63f4c7cbcdd8e18838d49a02b7305a0b4583e14
 DIST bcpkix-jdk15on-1.52-sources.jar 422301 SHA256 46dee0a923aac4e60432974685d585edc64274ae303818177e4778685e5adf4b SHA512 55f33846e16f7367a25df0933c904b435933e96d0e881bb949c3e3812618fc0d0b5a2901efa779e02a6f48157231da197e2bf5d8037b22169330fa374b07a988 WHIRLPOOL 95746d31ca1daac2ef0348a6f60d2d1122aeb5d945338d4f2398bee6e51e58040175063444cdb294e8c25c697115ddbb39b7508e563e09afe65b7813abddb221
-DIST bcpkix-jdk15on-150.tar.gz 1149901 SHA256 0be5bb948ec481b3d1f30ee80ef593b298b3782697f9eeee5c74cf270689b520 SHA512 17c5a9aa8c04defab46987063f847ee5fdedfc42d51e29ecad5053e3df5895c2c01899edb9222c3dab3ecf204eac9744249163dc2c1572fa2becaaf0924d2eb3 WHIRLPOOL 07197f1271ffc965479badcfd6b75450e5b0744f93031dd3721406dcac04c3f360b0d537cde3efa0f44f9ac06b4427a60f00743bfacd8dc7cf0a3d70193d5b32
-DIST bcpkix-jdk15on-152.tar.gz 1214022 SHA256 518205ea86f215a79267b7a64ea7ce29261f4983be1d3c2f6b6aa533092ce400 SHA512 a30f08aa6ae646219012b6e4763e57bd9021358ddc7d5ea588deb808a5555f67cc212a7d8cdc2a552922f550989d88965ba204521dd5bd9b17cfdb9ed09c3b5f WHIRLPOOL e9f855dc2571643fafaaa2167ba9afb5c34691966d86e6e712a5411467d47bcdac5fa15f5a3f736eb05092c25190e42c2fb40bbbce42d7dadd6fdce63fc8451a
diff --git a/dev-java/bcpkix/bcpkix-1.50.ebuild b/dev-java/bcpkix/bcpkix-1.50.ebuild
deleted file mode 100644 (file)
index 8a49e4e..0000000
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit java-pkg-2 java-ant-2
-
-MY_P="${PN}-jdk15on-${PV/./}"
-
-DESCRIPTION="Java cryptography APIs"
-HOMEPAGE="http://www.bouncycastle.org/java.html"
-SRC_URI="http://www.bouncycastle.org/download/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
-
-# Tests are currently broken. Needs further investigation.
-#
-#  - java.lang.RuntimeException: java.security.NoSuchProviderException:
-#    JCE cannot authenticate the provider BC
-#
-#  - error: package org.bouncycastle.util.test does not exist
-RESTRICT="test"
-
-COMMON_DEPEND="
-       >=dev-java/bcprov-${PV}:0[test?]"
-
-DEPEND=">=virtual/jdk-1.5
-       app-arch/unzip
-       test? ( dev-java/junit:0 )
-       ${COMMON_DEPEND}"
-
-RDEPEND=">=virtual/jre-1.5
-       ${COMMON_DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
-       default
-       cd "${S}"
-       unpack ./src.zip
-}
-
-java_prepare() {
-       mkdir "${S}"/classes
-
-       if use test ; then
-               java-pkg_jar-from --build-only junit
-       fi
-
-       java-pkg_jar-from bcprov
-}
-
-src_compile() {
-       find org -name "*.java" > "${T}"/src.list
-
-       local cp="bcprov.jar"
-       if use test ; then
-               cp="${cp}:junit.jar"
-       else
-               sed -i '/\/test\//d' "${T}"/src.list || die "Failed to remove test classes"
-       fi
-
-       ejavac -d "${S}"/classes -cp ${cp} "@${T}"/src.list
-
-       cd "${S}"/classes || die
-
-       jar -cf "${S}"/${PN}.jar * || die "Failed to create jar."
-}
-
-src_test() {
-       local cp="${PN}.jar:bcprov.jar:junit.jar"
-       local pkg="org.bouncycastle"
-
-       java -cp ${cp} ${pkg}.tsp.test.AllTests | tee tsp.tests
-       java -cp ${cp} ${pkg}.pkcs.test.AllTests | tee pkcs.tests
-       java -cp ${cp} ${pkg}.openssl.test.AllTests | tee openssl.tests
-       java -cp ${cp} ${pkg}.mozilla.test.AllTests | tee mozilla.tests
-       java -cp ${cp} ${pkg}.eac.test.AllTests | tee eac.tests
-       java -cp ${cp} ${pkg}.dvcs.test.AllTests | tee dvcs.tests
-       java -cp ${cp} ${pkg}.cms.test.AllTests | tee cms.tests
-       java -cp ${cp} ${pkg}.cert.test.AllTests | tee cert.tests
-       java -cp ${cp} ${pkg}.cert.ocsp.test.AllTests | tee cert.ocsp.tests
-       java -cp ${cp} ${pkg}.cert.crmf.test.AllTests | tee cert.crmf.tests
-       java -cp ${cp} ${pkg}.cert.cmp.test.AllTests | tee cert.cmp.tests
-
-       grep -q FAILURES *.tests && die "Tests failed."
-}
-
-src_install() {
-       java-pkg_dojar "${S}"/${PN}.jar
-
-       use source && java-pkg_dosrc org
-       use doc && java-pkg_dojavadoc docs
-}
diff --git a/dev-java/bcpkix/bcpkix-1.52.ebuild b/dev-java/bcpkix/bcpkix-1.52.ebuild
deleted file mode 100644 (file)
index 29e07b8..0000000
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit java-pkg-2 java-ant-2
-
-MY_P="${PN}-jdk15on-${PV/./}"
-
-DESCRIPTION="Java cryptography APIs"
-HOMEPAGE="http://www.bouncycastle.org/java.html"
-SRC_URI="http://www.bouncycastle.org/download/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
-
-# Tests are currently broken. Needs further investigation.
-#
-#  - java.lang.RuntimeException: java.security.NoSuchProviderException:
-#    JCE cannot authenticate the provider BC
-#
-#  - error: package org.bouncycastle.util.test does not exist
-RESTRICT="test"
-
-CDEPEND="
-       >=dev-java/bcprov-${PV}:0[test?]"
-
-DEPEND=">=virtual/jdk-1.6
-       app-arch/unzip
-       test? (
-               dev-java/junit:0
-       )
-       ${CDEPEND}"
-
-RDEPEND=">=virtual/jre-1.6
-       ${CDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
-       default
-       cd "${S}"
-       unpack ./src.zip
-}
-
-java_prepare() {
-       mkdir "${S}"/classes
-
-       if use test ; then
-               java-pkg_jar-from --build-only junit
-       fi
-
-       java-pkg_jar-from bcprov
-}
-
-src_compile() {
-       find org -name "*.java" > "${T}"/src.list
-
-       local cp="bcprov.jar"
-       if use test ; then
-               cp="${cp}:junit.jar"
-       else
-               sed -i '/\/test\//d' "${T}"/src.list || die "Failed to remove test classes"
-       fi
-
-       ejavac -d "${S}"/classes -cp ${cp} "@${T}"/src.list
-
-       cd "${S}"/classes || die
-
-       jar -cf "${S}"/${PN}.jar * || die "Failed to create jar."
-}
-
-src_test() {
-       local cp="${PN}.jar:bcprov.jar:junit.jar"
-       local pkg="org.bouncycastle"
-
-       java -cp ${cp} ${pkg}.tsp.test.AllTests | tee tsp.tests
-       java -cp ${cp} ${pkg}.pkcs.test.AllTests | tee pkcs.tests
-       java -cp ${cp} ${pkg}.openssl.test.AllTests | tee openssl.tests
-       java -cp ${cp} ${pkg}.mozilla.test.AllTests | tee mozilla.tests
-       java -cp ${cp} ${pkg}.eac.test.AllTests | tee eac.tests
-       java -cp ${cp} ${pkg}.dvcs.test.AllTests | tee dvcs.tests
-       java -cp ${cp} ${pkg}.cms.test.AllTests | tee cms.tests
-       java -cp ${cp} ${pkg}.cert.test.AllTests | tee cert.tests
-       java -cp ${cp} ${pkg}.cert.ocsp.test.AllTests | tee cert.ocsp.tests
-       java -cp ${cp} ${pkg}.cert.crmf.test.AllTests | tee cert.crmf.tests
-       java -cp ${cp} ${pkg}.cert.cmp.test.AllTests | tee cert.cmp.tests
-
-       grep -q FAILURES *.tests && die "Tests failed."
-}
-
-src_install() {
-       java-pkg_dojar "${S}"/${PN}.jar
-
-       use source && java-pkg_dosrc org
-       use doc && java-pkg_dojavadoc docs
-}