Bump to 3.2.7; Add Ruby 2.1 support
authorNaohiro Aota <naota@gentoo.org>
Wed, 16 Sep 2015 08:37:37 +0000 (17:37 +0900)
committerNaohiro Aota <naota@gentoo.org>
Wed, 16 Sep 2015 08:37:37 +0000 (17:37 +0900)
Package-Manager: portage-2.2.20.1

net-misc/mikutter/Manifest
net-misc/mikutter/mikutter-3.2.7.ebuild [new file with mode: 0644]
net-misc/mikutter/mikutter-9999.ebuild

index 69738071fc9858be511bceee07c99a2536e42db9..147f4ac283146f610990b59439a859fbcd80ad31 100644 (file)
@@ -1 +1,2 @@
 DIST mikutter.3.1.1.tar.gz 2556358 SHA256 b7c45048e4594542d78bb9cabe1911a69326f1311fc581fc346821c07c11b30d SHA512 fb0bf39444a06c58850990687a4b76f8bfb0cb91bb6501ac60565f06bb40431acf054a1a08a8a2fc29b1a0d852fb3444c478676f126ab20ae7db8d60f0870dca WHIRLPOOL ddceeb8e764b848543f00450f07a46140f8fa6908e3cf7e3fd420a2ea084f13e2e59965cbaed407195e475ebf1dced7ce099813e0efa6b858925e6728d128156
+DIST mikutter.3.2.7.tar.gz 2576878 SHA256 61108ff4c39073c5fb797cde072c48bc45f89fdb90c269815695fd31b1da89b6 SHA512 b54b4896e0321fcac7ec08dd2e5dc567631c803501cc4798c7062de31185306bb5e69603c32ecb64cdbcd5772fc2d92ea41949c4e79abebd252fc491a47056ad WHIRLPOOL 4168961d2d3235f3ae6c6294b64febf73ef8f40b9982c6bba44b1950f601a98ceada6fd3a8897e6f9b5e68d5874be5e99469f4679a2fc9aa1116886ebc17eca0
diff --git a/net-misc/mikutter/mikutter-3.2.7.ebuild b/net-misc/mikutter/mikutter-3.2.7.ebuild
new file mode 100644 (file)
index 0000000..cbb4ceb
--- /dev/null
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21"
+
+inherit eutils ruby-ng
+
+if [ "${PV}" = "9999" ]; then
+       EGIT_REPO_URI="git://toshia.dip.jp/mikutter.git"
+       inherit git-2
+       KEYWORDS=""
+       EGIT_SOURCEDIR="${WORKDIR}/all"
+else
+       MY_P="${PN}.${PV}"
+       SRC_URI="http://mikutter.hachune.net/bin/${MY_P}.tar.gz"
+       KEYWORDS="~amd64"
+       RUBY_S="${PN}"
+fi
+
+DESCRIPTION="Simple, powerful and moeful twitter client"
+HOMEPAGE="http://mikutter.hachune.net/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+libnotify sound"
+
+DEPEND=""
+RDEPEND="
+       libnotify? ( x11-libs/libnotify )
+       sound? ( media-sound/alsa-utils )"
+
+ruby_add_rdepend "dev-ruby/addressable
+       dev-ruby/bsearch
+       dev-ruby/delayer
+       dev-ruby/json
+       dev-ruby/memoize
+       >=dev-ruby/moneta-0.7
+       >=dev-ruby/oauth-0.4.7
+       dev-ruby/rcairo
+       >=dev-ruby/ruby-gettext-3.0.1
+       >=dev-ruby/ruby-gtk2-2.2.0
+       dev-ruby/ruby-hmac
+       dev-ruby/typed-array
+       virtual/ruby-ssl"
+
+all_ruby_unpack() {
+       if [ "${PV}" = "9999" ];then
+               git-2_src_unpack
+       else
+               default
+       fi
+}
+
+each_ruby_install() {
+       local rubyversion
+
+       if use ruby_targets_ruby22; then
+               rubyversion=ruby22
+       elif use ruby_targets_ruby21; then
+               rubyversion=ruby21
+       elif use ruby_targets_ruby20; then
+               rubyversion=ruby20
+       else
+               die "Select Ruby verion 2.x"
+       fi
+
+       exeinto /usr/share/mikutter
+       doexe mikutter.rb
+       insinto /usr/share/mikutter
+       doins -r core plugin
+       sed -e "s/ruby19/${rubyversion}/" "${FILESDIR}"/mikutter \
+               | newbin - mikutter
+       dodoc README
+       make_desktop_entry mikutter Mikutter \
+               /usr/share/mikutter/core/skin/data/icon.png
+}
index 5e49f50f5de6cfabe4409a088603417267bf1840..cbb4ceb37009986da9ec79370bae8cd961adef77 100644 (file)
@@ -4,7 +4,7 @@
 
 EAPI=5
 
-USE_RUBY="ruby20"
+USE_RUBY="ruby20 ruby21"
 
 inherit eutils ruby-ng
 
@@ -55,17 +55,24 @@ all_ruby_unpack() {
 }
 
 each_ruby_install() {
+       local rubyversion
+
+       if use ruby_targets_ruby22; then
+               rubyversion=ruby22
+       elif use ruby_targets_ruby21; then
+               rubyversion=ruby21
+       elif use ruby_targets_ruby20; then
+               rubyversion=ruby20
+       else
+               die "Select Ruby verion 2.x"
+       fi
+
        exeinto /usr/share/mikutter
        doexe mikutter.rb
        insinto /usr/share/mikutter
        doins -r core plugin
-       #if use ruby_targets_ruby21; then
-       #       sed -e 's/ruby19/ruby21/' "${FILESDIR}"/mikutter
-       if use ruby_targets_ruby20; then
-               sed -e 's/ruby19/ruby20/' "${FILESDIR}"/mikutter
-       else
-               die
-       fi | newbin - mikutter
+       sed -e "s/ruby19/${rubyversion}/" "${FILESDIR}"/mikutter \
+               | newbin - mikutter
        dodoc README
        make_desktop_entry mikutter Mikutter \
                /usr/share/mikutter/core/skin/data/icon.png