arm/ia64 stable
authorMike Frysinger <vapier@gentoo.org>
Sun, 28 Jan 2007 07:39:56 +0000 (07:39 +0000)
committerMike Frysinger <vapier@gentoo.org>
Sun, 28 Jan 2007 07:39:56 +0000 (07:39 +0000)
Package-Manager: portage-2.1.2-r4

dev-python/wxpython/wxpython-2.6.3.3.ebuild

index ad138e516271d39e0d7ab1b354fe1e497cd1ee7b..d052b98fb3f107e4b8085348e62ed9bf0d158086 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.3.3.ebuild,v 1.7 2007/01/23 13:08:11 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.3.3.ebuild,v 1.8 2007/01/28 07:39:56 vapier Exp $
 
 inherit python wxwidgets eutils multilib
 
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/wxpython/${MY_P}.tar.bz2"
 
 LICENSE="wxWinLL-3"
 SLOT="2.6"
-KEYWORDS="~alpha ~amd64 ~arm hppa ~ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
 IUSE="unicode opengl"
 
 RDEPEND=">=dev-lang/python-2.1
@@ -29,11 +29,11 @@ RDEPEND=">=dev-lang/python-2.1
 DEPEND="${RDEPEND}
        dev-util/pkgconfig"
 
-S="${WORKDIR}/${MY_P}/wxPython/"
+S=${WORKDIR}/${MY_P}/wxPython/
 
 src_unpack() {
        unpack ${A}
-       cd "${S}" || die "failed to cd to ${S}"
+       cd "${S}"
        sed -i "s:cflags.append('-O3'):pass:" config.py || die "sed failed"
        epatch "${FILESDIR}/scripts-multiver-2.6.1.0.diff"
 }
@@ -102,10 +102,8 @@ src_install() {
 }
 
 pkg_postinst() {
-
        elog "Gentoo now uses the Multi-version method for SLOT'ing"
        elog "Developers see this site for instructions on using 2.4 or 2.6"
        elog "with your apps:"
        elog "http://wiki.wxpython.org/index.cgi/MultiVersionInstalls"
 }
-