kde-plasma/plasma-workspace: Rename USE feedback to telemetry
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 23 Apr 2020 10:18:37 +0000 (12:18 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 23 Apr 2020 22:06:55 +0000 (00:06 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
kde-plasma/plasma-workspace/metadata.xml
kde-plasma/plasma-workspace/plasma-workspace-5.18.4.1.ebuild

index 418be213772d0a593ebe2b824f6dd8bdac4bb98a..81b172506439dc7306e507f9ae45b67926d5ef99 100644 (file)
@@ -7,9 +7,9 @@
        </maintainer>
        <use>
                <flag name="appstream">Enable AppStream software metadata support</flag>
-               <flag name="feedback">Enable User Feedback control module for <pkg>kde-plasma/systemsettings</pkg></flag>
                <flag name="geolocation">Enables dataengine providing location information</flag>
                <flag name="qalculate">Enable Qalculate runner using <pkg>sci-libs/libqalculate</pkg></flag>
                <flag name="qrcode">Enable support for creating QR codes from clipboard data using <pkg>kde-frameworks/prison</pkg></flag>
+               <flag name="telemetry">Enable User Feedback control module for <pkg>kde-plasma/systemsettings</pkg></flag>
        </use>
 </pkgmetadata>
index 86e79d857083141975ae99f75cffb604ca72a645..c71af205dabb40b97ca3630e5fa99b4df8727bf2 100644 (file)
@@ -16,7 +16,7 @@ DESCRIPTION="KDE Plasma workspace"
 LICENSE="GPL-2" # TODO: CHECK
 SLOT="5"
 KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-IUSE="appstream +calendar feedback geolocation gps qalculate qrcode +semantic-desktop systemd"
+IUSE="appstream +calendar geolocation gps qalculate qrcode +semantic-desktop systemd telemetry"
 
 REQUIRED_USE="gps? ( geolocation )"
 
@@ -87,12 +87,12 @@ COMMON_DEPEND="
        x11-libs/xcb-util-image
        appstream? ( dev-libs/appstream[qt5] )
        calendar? ( >=kde-frameworks/kholidays-${KFMIN}:5 )
-       feedback? ( dev-libs/kuserfeedback:5 )
        geolocation? ( >=kde-frameworks/networkmanager-qt-${KFMIN}:5 )
        gps? ( sci-geosciences/gpsd )
        qalculate? ( sci-libs/libqalculate:= )
        qrcode? ( >=kde-frameworks/prison-${KFMIN}:5 )
        semantic-desktop? ( >=kde-frameworks/baloo-${KFMIN}:5 )
+       telemetry? ( dev-libs/kuserfeedback:5 )
 "
 DEPEND="${COMMON_DEPEND}
        >=dev-qt/qtconcurrent-${QTMIN}:5
@@ -176,11 +176,11 @@ src_configure() {
                -DBUILD_xembed-sni-proxy=OFF
                $(cmake_use_find_package appstream AppStreamQt)
                $(cmake_use_find_package calendar KF5Holidays)
-               $(cmake_use_find_package feedback KUserFeedback)
                $(cmake_use_find_package geolocation KF5NetworkManagerQt)
                $(cmake_use_find_package qalculate Qalculate)
                $(cmake_use_find_package qrcode KF5Prison)
                $(cmake_use_find_package semantic-desktop KF5Baloo)
+               $(cmake_use_find_package telemetry KUserFeedback)
        )
 
        use geolocation && mycmakeargs+=( $(cmake_use_find_package gps libgps) )