media-libs/mutagen: 1.44.0
authorSebastian Pipping <sping@gentoo.org>
Thu, 5 Mar 2020 01:30:01 +0000 (02:30 +0100)
committerSebastian Pipping <sping@gentoo.org>
Thu, 5 Mar 2020 01:30:52 +0000 (02:30 +0100)
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.89, Repoman-2.3.20

media-libs/mutagen/Manifest
media-libs/mutagen/mutagen-1.44.0.ebuild [new file with mode: 0644]

index 4ba907793a7e0182f0d71ef76c819bb336de0251..a79bcd75a63c2316921da37afd53e53a099ad27c 100644 (file)
@@ -1 +1,2 @@
 DIST mutagen-1.43.0.tar.gz 1143839 BLAKE2B 044906b730763e001fa2cb863c8bb1fec45713aca57b6311f783f66218e4f3410987d04d56a1e4fbf41a229860bbb574b4077401e1f2384e70d80fdc9f3b23ad SHA512 66df63705a43befa9cf6688bc8b3acc4fd1559eb28920c105b47a97c35422b5e19527051445daa7aed66facc2e4c14d71058f8560bbd564fecbe56a076491e3f
+DIST mutagen-1.44.0.tar.gz 1143320 BLAKE2B 9e4ad11b7ee560a4940e3eaaecdb8b0fad4db54fd1fa9e4f925d84e55c217eb002e07602817fa92f6db9fdd6b6b339d5e147874bf587604c18b665d980d6604a SHA512 88c8c181b1333989451533951727b7c43e4a012defd3fd1f7ddd970d083f938783d61f98970e74c677ee9725dac92c47ee37af4bd7a474e85c7a56793c6063a8
diff --git a/media-libs/mutagen/mutagen-1.44.0.ebuild b/media-libs/mutagen/mutagen-1.44.0.ebuild
new file mode 100644 (file)
index 0000000..ab9df43
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Audio metadata tag reader and writer implemented in pure Python"
+HOMEPAGE="https://github.com/quodlibet/mutagen https://pypi.org/project/mutagen/"
+SRC_URI="https://github.com/quodlibet/mutagen/releases/download/release-${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+# TODO: Missing support for >=dev-python/eyeD3-0.7 API
+# test? ( >=dev-python/eyeD3-0.7 )
+BDEPEND="
+       doc? ( dev-python/sphinx )
+       test? (
+               dev-python/hypothesis[${PYTHON_USEDEP}]
+               dev-python/pyflakes[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
+       )
+"
+
+RESTRICT="!test? ( test )"
+
+python_compile_all() {
+       use doc && emake -C docs
+}
+
+python_test() {
+       esetup.py test --no-quality
+}
+
+python_install_all() {
+       local DOCS=( NEWS README.rst )
+       use doc && local HTML_DOCS=( docs/_build/. )
+       distutils-r1_python_install_all
+}