Fixed crash due to X11 shared memory extension. Misc cleanings.
authorPeter Volkov <pva@gentoo.org>
Wed, 14 Jun 2006 14:17:05 +0000 (14:17 +0000)
committerPeter Volkov <pva@gentoo.org>
Wed, 14 Jun 2006 14:17:05 +0000 (14:17 +0000)
Package-Manager: portage-2.0.54-r2

app-emulation/e-uae/ChangeLog
app-emulation/e-uae/Manifest
app-emulation/e-uae/e-uae-0.8.28.ebuild
app-emulation/e-uae/files/e-uae-0.8.28-shm-crash.patch [new file with mode: 0644]

index 4c186dc67f79e2cb6b15bfc4d478f4f0a2bc0ee5..60d09af76b9a160866173c2ec9e5158e63ba9da6 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for app-emulation/e-uae
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/e-uae/ChangeLog,v 1.8 2006/06/13 14:00:48 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/e-uae/ChangeLog,v 1.9 2006/06/14 14:17:05 pva Exp $
+
+  14 Jun 2006; Peter Volkov <pva@gentoo.org>
+  +files/e-uae-0.8.28-shm-crash.patch, e-uae-0.8.28.ebuild:
+  Fixed crash due to X11 shared memory extension. Misc cleanings.
 
 *e-uae-0.8.28 (13 Jun 2006)
 
index eb86118d69cca1754677fc4c4903545f00a66c64..96b6ed29f2ee2503ec91066d513417a84590127e 100644 (file)
@@ -1,6 +1,7 @@
-MD5 b5c8caffe8ce689bc9a46ddf1b867a28 ChangeLog 1291
+MD5 9464ea4152adbbdd977cf85960bb365d ChangeLog 1463
 MD5 624de9bf2b723d7882a4a8e2485f71ef e-uae-0.8.27.ebuild 1635
-MD5 d8784080ca3a3c8f3d34883715252955 e-uae-0.8.28.ebuild 3591
+MD5 1a85d3c4ef89e6d13eacb5f5a9f0b15d e-uae-0.8.28.ebuild 3431
 MD5 851c3d9c0e2846a1241c99e5ff19bf01 files/digest-e-uae-0.8.27 66
 MD5 856093362e575805efb4ef8117d8f98c files/digest-e-uae-0.8.28 66
+MD5 774c0436b6e91dd8f18b0df23f10c75b files/e-uae-0.8.28-shm-crash.patch 582
 MD5 107be5d8d010a6b3dac228473128bdf4 metadata.xml 468
index 876776d8ed930b8773d2d362c421cba3bc192fe4..b07c8697dc5aa3ffcfcee43d40fa023db94ee250 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/e-uae/e-uae-0.8.28.ebuild,v 1.1 2006/06/13 14:00:48 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/e-uae/e-uae-0.8.28.ebuild,v 1.2 2006/06/14 14:17:05 pva Exp $
 
 inherit eutils flag-o-matic
 
@@ -13,8 +13,6 @@ SLOT="0"
 KEYWORDS="~amd64 ~ppc ~x86"
 IUSE="X dga ncurses sdl gtk alsa oss sdl-sound capslib"
 
-# app-emulation/e-uae:sdl-sound - Use media-libs/sdl-sound for audio output.
-# app-emulation/e-uae:capslib - Add CAPS library support.
 # Note: opposed to ./configure --help zlib support required! Check
 # src/Makefile.am that includes zfile.c unconditionaly.
 RDEPEND="X? ( || ( ( x11-libs/libXt
@@ -65,7 +63,7 @@ pkg_setup() {
 
        # VIDEO setup. X is autodetected (there is no --with-X option).
        if use X ; then
-               myconf="$myconf --without-curses --without-sdl-gfx --enable-vidmode"
+               myconf="$myconf --without-curses --without-sdl-gfx"
                use dga && myconf="$myconf --enable-dga --enable-vidmode"
        elif use sdl ; then
                myconf="$myconf --with-sdl --with-sdl-gfx --without-curses"
@@ -91,13 +89,16 @@ pkg_setup() {
        myconf="$myconf --enable-bsdsock"
 }
 
+src_unpack() {
+       unpack ${A}
+       cd ${S}
+
+       epatch ${FILESDIR}/e-uae-0.8.28-shm-crash.patch
+}
+
 src_compile() {
        strip-flags
 
-#      export WANT_AUTOMAKE=1.7
-#      export WANT_AUTOCONF=2.5
-#      ./bootstrap.sh || die "bootstrap failed"
-
        econf ${myconf} \
                --with-libscg-includedir=/usr/include/scsilib \
                || die "./configure failed"
diff --git a/app-emulation/e-uae/files/e-uae-0.8.28-shm-crash.patch b/app-emulation/e-uae/files/e-uae-0.8.28-shm-crash.patch
new file mode 100644 (file)
index 0000000..0607cdc
--- /dev/null
@@ -0,0 +1,12 @@
+diff -Naur e-uae-0.8.28.orig/src/gfx-x11/xwin.c e-uae-0.8.28/src/gfx-x11/xwin.c
+--- e-uae-0.8.28.orig/src/gfx-x11/xwin.c       2005-08-21 19:10:40.000000000 +0400
++++ e-uae-0.8.28/src/gfx-x11/xwin.c    2006-06-14 17:50:29.000000000 +0400
+@@ -1215,7 +1215,7 @@
+     if (! dgamode) {
+       if (! screen_is_picasso && refresh_necessary) {
+-          DO_PUTIMAGE (ami_dinfo.ximg, 0, 0, 0, 0, currprefs.gfx_width_fs, currprefs.gfx_height_fs);
++          DO_PUTIMAGE (ami_dinfo.ximg, 0, 0, 0, 0, current_width, current_height);
+           refresh_necessary = 0;
+       }
+       if (cursorOn && !currprefs.x11_hide_cursor) {