net-p2p/transmission: switch to cmake eclass
authorMike Gilbert <floppym@gentoo.org>
Mon, 20 Apr 2020 19:18:14 +0000 (15:18 -0400)
committerMike Gilbert <floppym@gentoo.org>
Mon, 20 Apr 2020 19:18:33 +0000 (15:18 -0400)
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
net-p2p/transmission/transmission-9999.ebuild

index b15f594478bb9d249f5e8ad18b416fb0b0b4ebb4..f7f2735ac3c6da8e79fb2c070613158482806cca 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 2006-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-inherit cmake-utils systemd xdg-utils
+inherit cmake systemd xdg-utils
 
 if [[ ${PV} == 9999 ]]; then
        inherit git-r3
@@ -115,11 +115,11 @@ src_configure() {
                -DWITH_SYSTEMD=$(usex systemd ON OFF)
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
 
        newinitd "${FILESDIR}"/transmission-daemon.initd.10 transmission-daemon
        newconfd "${FILESDIR}"/transmission-daemon.confd.4 transmission-daemon