sys-cluster/slurm: Version Bump
authorJustin Lecher <jlec@gentoo.org>
Sun, 7 Jul 2019 17:49:08 +0000 (18:49 +0100)
committerJustin Lecher <jlec@gentoo.org>
Mon, 8 Jul 2019 19:35:26 +0000 (20:35 +0100)
Clean mysql deps
Install torque wrapper correctly

Closes: https://bugs.gentoo.org/666102
Closes: https://bugs.gentoo.org/676916
Closes: https://bugs.gentoo.org/666072
Closes: https://bugs.gentoo.org/506706
Package-Manager: Portage-2.3.68, Repoman-2.3.16
Signed-off-by: Justin Lecher <jlec@gentoo.org>
sys-cluster/slurm/Manifest
sys-cluster/slurm/files/slurm-17.11.13.2-disable-sview.patch [moved from sys-cluster/slurm/files/slurm-17.11.12-disable-sview.patch with 100% similarity]
sys-cluster/slurm/files/slurm-18.08.7-disable-sview.patch [moved from sys-cluster/slurm/files/slurm-18.08.3-disable-sview.patch with 100% similarity]
sys-cluster/slurm/metadata.xml
sys-cluster/slurm/slurm-17.11.13.2.ebuild [moved from sys-cluster/slurm/slurm-17.11.12.ebuild with 97% similarity]
sys-cluster/slurm/slurm-18.08.7.ebuild [moved from sys-cluster/slurm/slurm-18.08.3-r1.ebuild with 97% similarity]

index 9ef55782fc501df90993212be625586f471ee861..5d692ad2b82ca567d69aee819e59a1e0385e1684 100644 (file)
@@ -1,2 +1,2 @@
-DIST slurm-17.11.12.tar.bz2 6257065 BLAKE2B 3427645f9e54e90ce5f61395a1df7f2c1c9f5582e25780daab8a05dbe92bd39841356df8e66334bc3d8ee3d81f6a56b344e81ed142cd354d22fbdb4729c554d1 SHA512 bd59d2d9291e00c9ab71479e2190b89a7798f1ba9a4320b003d7c1ad6d62983c1d3debfdbdfc6e0abaf66472be6e3108c4969feb151e30874d3b51f53d213803
-DIST slurm-18.08.3.tar.bz2 6092020 BLAKE2B 63d5c7682decadc723637293660057a27a20b5ba4f0e0d53708091b86b59ed05c28ad19a70b2cf6d7c1e58df81f12fb2b5e26e44fa06cb5deacde5cd5b7db0f7 SHA512 2d1018e5b1520a5d71825d548d91d06d0f0a8df92b33f87d21a2238a5245a1199ca588370aea1df6ad9d09242df9a6af19ea80357dae41a0337812617721c8bf
+DIST slurm-17.11.13-2.tar.bz2 6261416 BLAKE2B bca7a06e703799371da11a7427ce009784c7236569f4b24b278078231192bb0e90604fb90a61f8269881ccacd154cbf03174b3e4600410a8c726beccf4aefd18 SHA512 d419984bfa1bf1be20d3439672eaf868e3e0c45549b8d696bb6f588a57e1bc1e765dbca8a9a62c54bf27c3dfbbd0f165f573459a22ef87d976bc511c22fde639
+DIST slurm-18.08.7.tar.bz2 6186006 BLAKE2B a5458f72cbe93bc1103c2c7f3d428ae14239cb092edad2c683e448dda35f3e108fef0d9a3a86599da6058c9c98a86dafed9a087ffe6e8d7425db9cdb879954b3 SHA512 d0047086f1b716877cc5bb39539bf96a8fd08b1851c85fd85112c6432c1ce2a0f29fc9dd8803094c8fa44d063cec5f417e6bed231b6d338934ff4b48424a5a93
index 433eeb9e04ccbd80960c9914c135e941820c9e17..ddcebd29a6729f4d4b3b570527c1141d85d6b045 100644 (file)
@@ -17,6 +17,7 @@
                <flag name="netloc">Add support for netloc (amd64 only)</flag>
                <flag name="numa">Add NUMA awareness</flag>
                <flag name="ofed">Add Infiniband support via ofed</flag>
+               <flag name="slurmdbd">Install SQL server for slurmdbd</flag>
                <flag name="torque">Enable perl scripts that emulates pbs (qstat, qsub etc.)</flag>
        </use>
 </pkgmetadata>
similarity index 97%
rename from sys-cluster/slurm/slurm-17.11.12.ebuild
rename to sys-cluster/slurm/slurm-17.11.13.2.ebuild
index 67111e2fac8cb3d3f65c68f727f59d148fabdf33..d669350a8a3e59e66340d523253f1b130b133d52 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -30,14 +30,17 @@ HOMEPAGE="https://www.schedmd.com"
 
 LICENSE="GPL-2"
 SLOT="0"
-IUSE="debug hdf5 html ipmi json lua multiple-slurmd +munge mysql netloc numa ofed pam perl ssl static-libs torque X"
+IUSE="debug hdf5 html ipmi json lua multiple-slurmd +munge mysql netloc numa ofed pam perl slurmdbd ssl static-libs torque X"
 
 CDEPEND="
        !sys-cluster/torque
        !net-analyzer/slurm
        !net-analyzer/sinfo
        || ( sys-cluster/pmix[-pmi] >=sys-cluster/openmpi-2.0.0 )
-       mysql? ( virtual/mysql )
+       mysql? (
+               || ( dev-db/mariadb-connector-c dev-db/mysql-connector-c )
+               slurmdbd? ( || ( dev-db/mariadb dev-db/mysql ) )
+               )
        munge? ( sys-auth/munge )
        pam? ( virtual/pam )
        ssl? ( dev-libs/openssl:0= )
@@ -70,6 +73,8 @@ PATCHES=(
        "${FILESDIR}"/${P}-disable-sview.patch
 )
 
+S="${WORKDIR}/${MY_P}"
+
 src_unpack() {
        if [[ ${PV} == *9999* ]]; then
                git-r3_src_unpack
similarity index 97%
rename from sys-cluster/slurm/slurm-18.08.3-r1.ebuild
rename to sys-cluster/slurm/slurm-18.08.7.ebuild
index 92e034a9760eaa876f61df5640d9cffa9c7b23c8..5a7bf934b197cdf0d7da60947ccb42fd0099354a 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -30,14 +30,17 @@ HOMEPAGE="https://www.schedmd.com"
 
 LICENSE="GPL-2"
 SLOT="0"
-IUSE="debug hdf5 html ipmi json lua multiple-slurmd +munge mysql netloc numa ofed pam perl ssl static-libs torque X"
+IUSE="debug hdf5 html ipmi json lua multiple-slurmd +munge mysql netloc numa ofed pam perl slurmdbd ssl static-libs torque X"
 
 CDEPEND="
        !sys-cluster/torque
        !net-analyzer/slurm
        !net-analyzer/sinfo
        || ( sys-cluster/pmix[-pmi] >=sys-cluster/openmpi-2.0.0 )
-       mysql? ( virtual/mysql )
+       mysql? (
+               || ( dev-db/mariadb-connector-c dev-db/mysql-connector-c )
+               slurmdbd? ( || ( dev-db/mariadb dev-db/mysql ) )
+               )
        munge? ( sys-auth/munge )
        pam? ( virtual/pam )
        ssl? ( dev-libs/openssl:0= )