sys-apps/pcsc-tools: fix bug 698268, improve ebuild
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>
Wed, 13 Nov 2019 17:52:05 +0000 (18:52 +0100)
committerAaron Bauman <bman@gentoo.org>
Mon, 18 Nov 2019 22:16:48 +0000 (17:16 -0500)
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com>
Closes: https://bugs.gentoo.org/698268
Closes: https://github.com/gentoo/gentoo/pull/13635
Signed-off-by: Aaron Bauman <bman@gentoo.org>
sys-apps/pcsc-tools/pcsc-tools-1.5.3.ebuild

index 9bbbd54dd2a91700bfa7a9867bf0179e8fa46ac7..490d6c2f740d2ae6a6f79eff38b84bdbe99e6360 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-inherit eutils fdo-mime multilib toolchain-funcs
+inherit desktop toolchain-funcs xdg-utils
 
 DESCRIPTION="PC/SC Architecture smartcard tools"
 HOMEPAGE="http://ludovic.rousseau.free.fr/softwares/pcsc-tools/"
@@ -24,11 +24,6 @@ DOCS=(
        README Changelog
 )
 
-src_prepare() {
-       default
-       sed -i -e 's:-Wall -O2:$(CFLAGS):g' Makefile
-}
-
 src_compile() {
        # explicitly only build the pcsc_scan application, or the man
        # pages will be gzipped first, and then unpacked.
@@ -59,9 +54,9 @@ src_install() {
 }
 
 pkg_postinst() {
-       use gtk && fdo-mime_desktop_database_update
+       use gtk && xdg_desktop_database_update
 }
 
 pkg_postrm() {
-       fdo-mime_desktop_database_update
+       xdg_desktop_database_update
 }